summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoe Dillon2019-12-24 20:41:32 +0000
committerJoe Dillon2019-12-24 20:41:32 +0000
commit51380177e2dda1d4ad50e3bd378c082f851ba0ac (patch)
tree3602aa25ba571a5ec7f83b3ab6f312066631e907
downloadaur-51380177e2dda1d4ad50e3bd378c082f851ba0ac.tar.gz
1.0.0 - initial release.
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD22
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a35513229eb2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = taps
+ pkgdesc = True Arch package security - audit your system and query packages
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/Vimru/taps
+ arch = any
+ license = GPL3
+ depends = python-setuptools
+ source = https://files.pythonhosted.org/packages/source/t/taps/taps-1.0.0.tar.gz
+ sha256sums = 056e4e95b885769c7328694d8fe42fc82b5f7f7c73dfc8b564c7a4b7ccafe8e5
+
+pkgname = taps
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bc7ba27447e9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Joe Dillon <josephd31415 at gmail dot com>
+pkgname=taps
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="True Arch package security - audit your system and query packages"
+arch=("any")
+url="https://github.com/Vimru/taps"
+license=("GPL3")
+depends=("python-setuptools")
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
+sha256sums=('056e4e95b885769c7328694d8fe42fc82b5f7f7c73dfc8b564c7a4b7ccafe8e5')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}
+