summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-03-14 06:39:08 +0200
committerDimitris Kiziridis2020-03-14 06:39:08 +0200
commit56afc5661acae2251de16c347ed1b94a9dae17a9 (patch)
tree011f21212bf909c42addfee97f5e282ecfddbc57
downloadaur-56afc5661acae2251de16c347ed1b94a9dae17a9.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..508862f17837
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = taptempo
+ pkgdesc = A command line tap tempo. Hit enter key with style and you'll get the corresponding number of beats per minute (BPM). This tool is very useful to quickly find the tempo of a song without launching a big digital workstation like Ardour or LMMS
+ pkgver = 1.4.4
+ pkgrel = 1
+ url = https://taptempo.tuxfamily.org
+ arch = x86_64
+ license = GPL3
+ makedepends = catch2
+ makedepends = gettext
+ makedepends = cmake
+ source = https://download.tuxfamily.org/taptempo/1.4.4/taptempo-1.4.4.tar.gz
+ md5sums = 6b7d859049f41de3bf17c38a0f6aedf4
+
+pkgname = taptempo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..42d8d274eda0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=taptempo
+pkgver=1.4.4
+pkgrel=1
+pkgdesc="A command line tap tempo. Hit enter key with style and you'll get the corresponding number of beats per minute (BPM). This tool is very useful to quickly find the tempo of a song without launching a big digital workstation like Ardour or LMMS"
+arch=('x86_64')
+url="https://taptempo.tuxfamily.org"
+license=('GPL3')
+makedepends=('catch2' 'gettext' 'cmake')
+source=("https://download.tuxfamily.org/taptempo/${pkgver}/taptempo-${pkgver}.tar.gz")
+md5sums=('6b7d859049f41de3bf17c38a0f6aedf4')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ mkdir _build
+ cd _build
+ cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr ..
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver/_build"
+ DESTDIR=$pkgdir make install
+} \ No newline at end of file