summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F Rødseth2015-06-10 15:20:44 +0200
committerAlexander F Rødseth2015-06-10 15:20:44 +0200
commit9852ee893bc829c6bb127cde35e30c44ba1bf986 (patch)
tree1b9a913cf150bf13979d377c9feb8f0fafe8898c
downloadaur-9852ee893bc829c6bb127cde35e30c44ba1bf986.tar.gz
Initial import
-rw-r--r--.AURINFO15
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
3 files changed, 64 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..405abf898f4a
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,15 @@
+pkgbase = tardisgo
+ pkgdesc = Create mobile applications with Go, by transpiling to Haxe
+ pkgver = 0.1
+ pkgrel = 2
+ url = http://tardisgo.github.io/
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = go
+ makedepends = git
+ depends = haxe
+ source = git://github.com/tardisgo/tardisgo.git#tag=v0.1
+
+pkgname = tardisgo
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..95f27a137154
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = tardisgo
+ pkgdesc = Create mobile applications with Go, by transpiling to Haxe
+ pkgver = 0.1
+ pkgrel = 2
+ url = http://tardisgo.github.io/
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = go
+ makedepends = git
+ depends = haxe
+ source = git://github.com/tardisgo/tardisgo.git#tag=v0.1
+ md5sums = SKIP
+
+pkgname = tardisgo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..573acbe314ee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Alexander Rødseth <rodseth@gmail.com>
+
+pkgname=tardisgo
+pkgver=0.1
+pkgrel=2
+pkgdesc='Create mobile applications with Go, by transpiling to Haxe'
+arch=('x86_64' 'i686')
+url='http://tardisgo.github.io/'
+license=('MIT')
+makedepends=('go' 'git')
+depends=('haxe')
+source=("git://github.com/tardisgo/tardisgo.git#tag=v$pkgver")
+md5sums=('SKIP')
+
+prepare() {
+ export GOPATH="$srcdir"
+ go get golang.org/x/tools/go 2>/dev/null || true
+}
+
+build() {
+ export GOPATH="$srcdir"
+ go get -u github.com/tardisgo/tardisgo
+ rm -rf "$srcdir/src/github.com/tardisgo/tardisgo"
+ mv tardisgo "$srcdir/src/github.com/tardisgo/"
+}
+
+package() {
+ install -Dm755 "bin/$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 "src/github.com/$pkgname/$pkgname/LICENSE" \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: