summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Dewender2013-11-01 18:03:19 +0100
committerJohannes Dewender2013-11-01 18:03:19 +0100
commit11592d2d983209fcd4c1a68980164b5c532e7c8c (patch)
tree1a30e7cbf4fdab72d052ff05e412c50a385674e8
parente26959e2482c0e00c4b0085649943423234c1e24 (diff)
downloadaur-11592d2d983209fcd4c1a68980164b5c532e7c8c.tar.gz
targetcli-fb: 2.1.fb31, using Python 3
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9e6069bbef40..eac66741ef03 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,18 @@
pkgbase = targetcli-fb
pkgdesc = free branch of the targetcli LIO administration shell (iSCSI + Co)
- pkgver = 2.1.fb30
- pkgrel = 3
+ pkgver = 2.1.fb31
+ pkgrel = 1
url = https://github.com/agrover/targetcli-fb
arch = any
license = Apache
- depends = python2-rtslib-fb>=2.1.fb33
- depends = python2-configshell-fb
- depends = python2-ethtool
+ depends = python-rtslib-fb>=2.1.fb33
+ depends = python-configshell-fb
provides = targetcli
conflicts = lio-utils
- replaces = rtsadmin
- source = https://fedorahosted.org/releases/t/a/targetcli-fb/targetcli-fb-2.1.fb30.tar.gz
+ source = https://fedorahosted.org/releases/t/a/targetcli-fb/targetcli-fb-2.1.fb31.tar.gz
source = target.service
source = target
- md5sums = c5993434d606ad722d6939fd519f519d
+ md5sums = 12db6c11794fdff7c704107d72720379
md5sums = f462e9a5852346c66b77793565ddbc67
md5sums = f23bd6d5d4021c29b4519e40b3b9e042
diff --git a/PKGBUILD b/PKGBUILD
index 9fbc88f8f4c7..1eb428b6b40d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,36 @@
# Contributor: Johannes Dewender arch at JonnyJD dot net
pkgname=targetcli-fb
-pkgver=2.1.fb30
-pkgrel=3
+pkgver=2.1.fb31
+pkgrel=1
epoch=
pkgdesc="free branch of the targetcli LIO administration shell (iSCSI + Co)"
arch=('any')
url="https://github.com/agrover/targetcli-fb"
license=('Apache')
groups=()
-depends=('python2-rtslib-fb>=2.1.fb33' 'python2-configshell-fb' 'python2-ethtool')
+depends=('python-rtslib-fb>=2.1.fb33' 'python-configshell-fb')
optdepends=()
conflicts=('lio-utils')
provides=('targetcli')
-replaces=('rtsadmin')
backup=()
options=()
install=
source=(https://fedorahosted.org/releases/t/a/targetcli-fb/$pkgname-$pkgver.tar.gz
target.service
target)
-md5sums=('c5993434d606ad722d6939fd519f519d'
+md5sums=('12db6c11794fdff7c704107d72720379'
'f462e9a5852346c66b77793565ddbc67'
'f23bd6d5d4021c29b4519e40b3b9e042')
build() {
cd "$srcdir/$pkgname-$pkgver"
- python2 setup.py build
+ python setup.py build
gzip --stdout targetcli.8 > "targetcli.8.gz"
}
package() {
cd "$srcdir/$pkgname-$pkgver"
- python2 setup.py install --skip-build --root="$pkgdir/" --optimize=1
+ python setup.py install --skip-build --root="$pkgdir/" --optimize=1
install -D -m 644 targetcli.8.gz "$pkgdir/usr/share/man/man8/targetcli.8.gz"