summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Wilson2019-03-17 11:28:00 +0000
committerMartin Wilson2019-03-17 11:28:00 +0000
commita2804f797c08d9ec22e997d5baea03c0eff261e9 (patch)
treee3bb8b02b5e1873fc6639e7446ddd5b4f89553db
downloadaur-a2804f797c08d9ec22e997d5baea03c0eff261e9.tar.gz
init
-rw-r--r--.SRCINFO20
-rw-r--r--CMakeListsPatch.txt13
-rw-r--r--PKGBUILD37
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e75d5ec1076a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = tarquin
+ pkgdesc = An analysis tool for automatically determining the quantities of molecules present in MR spectroscopy data
+ pkgver = 4.3.12
+ pkgrel = 1
+ url = http://tarquin.sourceforge.net/
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = gcc-fortran
+ makedepends = boost
+ depends = lapack
+ depends = protobuf
+ depends = fftw
+ depends = gnuplot
+ depends = qwt5
+ source = https://github.com/martin3141/tarquin/archive/v4.3.12.tar.gz
+ md5sums = 9886ccd6eaaa35b7b60a26fd56cafecd
+
+pkgname = tarquin
+
diff --git a/CMakeListsPatch.txt b/CMakeListsPatch.txt
new file mode 100644
index 000000000000..1fe0c1f865f2
--- /dev/null
+++ b/CMakeListsPatch.txt
@@ -0,0 +1,13 @@
+--- CMakeLists.txt 2019-03-16 16:10:00.160047036 +0000
++++ CMakeLists_arch.txt 2019-03-16 16:09:46.700046293 +0000
+@@ -28,8 +28,8 @@
+ set( FFTW_LIB -lfftw3 )
+ #set( FFTW_LIB /usr/lib/i386-linux-gnu/libfftw3.a )
+
+- set( QWT_INCLUDE /usr/include/qwt-qt4 )
+- set( QWT_LIB -lqwt-qt4 )
++ set( QWT_INCLUDE /usr/include/qwt5 )
++ set( QWT_LIB -lqwt5 )
+
+ #set( QWT_INCLUDE /usr/local/qwt-5.2.3/include )
+ #set( QWT_LIB /usr/local/qwt-5.2.3/lib/libqwt.a )
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2ca15eb56853
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Martin Wilson <martin at pipegrep dot co dot uk>
+
+pkgname=tarquin
+pkgver=4.3.12
+pkgrel=1
+pkgdesc="An analysis tool for automatically determining the quantities of molecules present in MR spectroscopy data"
+arch=("x86_64")
+url="http://tarquin.sourceforge.net/"
+license=("GPL")
+depends=("lapack" "protobuf" "fftw" "gnuplot" "qwt5")
+makedepends=("cmake" "gcc-fortran" "boost")
+source=("https://github.com/martin3141/tarquin/archive/v$pkgver.tar.gz")
+md5sums=("9886ccd6eaaa35b7b60a26fd56cafecd")
+
+prepare() {
+ # patch master CMakeLists.txt
+ cd "$srcdir"/$pkgname-$pkgver/src
+ patch -Np0 -i ../../../CMakeListsPatch.txt
+ # update protobuf files
+ cd "$srcdir"/$pkgname-$pkgver/src/common
+ ./gen_proto.sh
+ # make the build directory
+ cd "$srcdir"/$pkgname-$pkgver/src
+ mkdir -p build
+}
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver/src/build
+ cmake -DCMAKE_BUILD_TYPE=Release ../
+ make
+}
+
+package() {
+ mkdir -p "$pkgdir"/usr/bin
+ cp "$srcdir"/$pkgname-$pkgver/src/build/redist/tarquin "$pkgdir"/usr/bin
+ cp "$srcdir"/$pkgname-$pkgver/src/build/redist/tarquingui "$pkgdir"/usr/bin
+}