summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTingPing2015-06-08 05:27:01 -0400
committerTingPing2015-06-08 05:28:58 -0400
commit445efbfadedb413fcdf5781faab4c085483c2be2 (patch)
treee47c7fb7ae20c25160fdb7303727b46bc74b87a1
downloadaur-445efbfadedb413fcdf5781faab4c085483c2be2.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..77f1627b547f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = tartan
+ pkgdesc = Clang analysis plugin for GLib and GNOME
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://people.collabora.com/~pwith/gnome-clang/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = llvm
+ depends = clang
+ depends = glib2
+ depends = gobject-introspection
+ source = https://github.com/pwithnall/tartan/archive/0.2.0.tar.gz
+ sha256sums = d73a0e4bda475498a69cbfc11d2e9b142b483d7a67f55b24642915e796c51115
+
+pkgname = tartan
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..07ccf36a27ad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: TingPing <tingping@tingping.se>
+
+pkgname='tartan'
+pkgver=0.2.0
+pkgrel=1
+pkgdesc='Clang analysis plugin for GLib and GNOME'
+url='https://people.collabora.com/~pwith/gnome-clang/'
+arch=('i686' 'x86_64')
+license='GPL3'
+depends=('llvm' 'clang' 'glib2' 'gobject-introspection')
+source=("https://github.com/pwithnall/tartan/archive/$pkgver.tar.gz")
+# Alt: https://git.collabora.com/git/tartan.git
+sha256sums=('d73a0e4bda475498a69cbfc11d2e9b142b483d7a67f55b24642915e796c51115')
+
+build() {
+ cd "$srcdir/$pkgname"
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+
+ DESTDIR=$pkgdir make install
+}