summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoriamawacko2024-06-04 20:05:35 -0700
committeriamawacko2024-06-04 20:05:35 -0700
commit7f2d3e756412e04f9e871a28e3bcced39dc6441b (patch)
tree87601f97adb4b434a93a67128e792a76dce4d62d
downloadaur-7f2d3e756412e04f9e871a28e3bcced39dc6441b.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD23
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..233c20716c80
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = tartufo
+ pkgdesc = Searches through git repositories for high entropy strings and secrets, digging deep into commit history
+ pkgver = 5.0.0
+ pkgrel = 1
+ url = https://tartufo.readthedocs.io/
+ arch = any
+ license = GPL-2.0-only
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ depends = python-pygit2
+ depends = python-gitpython
+ depends = python-click
+ depends = python-colorama
+ depends = python-tomlkit
+ depends = python-cached-property
+ source = https://files.pythonhosted.org/packages/source/t/tartufo/tartufo-5.0.0.tar.gz
+ sha256sums = 99ab6652cae6de295aeb31089e9ba27d66d0ad695af493d2d5cbc795397d1c84
+
+pkgname = tartufo
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e720da5ffa67
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: iamawacko <iamawacko@protonmail.com>
+pkgname=tartufo
+pkgver=5.0.0
+pkgrel=1
+pkgdesc="Searches through git repositories for high entropy strings and secrets, digging deep into commit history"
+url="https://tartufo.readthedocs.io/"
+arch=('any')
+license=('GPL-2.0-only')
+_name="tartufo"
+depends=(python-pygit2 python-gitpython python-click python-colorama python-tomlkit python-cached-property)
+makedepends=(python-build python-installer python-wheel)
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/tartufo/tartufo-$pkgver.tar.gz")
+sha256sums=('99ab6652cae6de295aeb31089e9ba27d66d0ad695af493d2d5cbc795397d1c84')
+
+build() {
+ cd $_name-$pkgver
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd $_name-$pkgver
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}