summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDario Ostuni2018-06-10 18:31:04 +0200
committerDario Ostuni2018-06-10 18:31:04 +0200
commita3ea5f6e241955e7e3c52621bd91ebbb692a553b (patch)
tree0fdd5dbd7399b3dc8077b2512ba7cf3fcfe655b4
parentc60e694e80298fafdb2c589d72256818eed12628 (diff)
downloadaur-a3ea5f6e241955e7e3c52621bd91ebbb692a553b.tar.gz
Bump version
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
-rwxr-xr-xlauncher3
3 files changed, 22 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7a423a36536b..c5bc76c7e277 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Apr 17 17:05:42 UTC 2018
+# Sun Jun 10 16:31:00 UTC 2018
pkgbase = task-maker-git
pkgdesc = The new cmsMake!
- pkgver = r378.bcb4240
+ pkgver = r504.34e4020
pkgrel = 1
url = https://github.com/algorithm-ninja/task-maker
arch = i686
@@ -10,15 +10,20 @@ pkgbase = task-maker-git
arch = armv7h
arch = aarch64
license = MPL2
- makedepends = bazel
+ makedepends = cmake
+ makedepends = gmock
+ makedepends = gtest
+ makedepends = cli11
+ makedepends = nlohmann-json
+ makedepends = plog
+ makedepends = python-pip
depends = python
- depends = libyaml
+ depends = protobuf
+ depends = grpc
provides = task-maker
conflicts = task-maker
source = git+https://github.com/algorithm-ninja/task-maker.git
- source = launcher
sha384sums = SKIP
- sha384sums = 28377283ca07a411f1283e8067a30903a4726f66f765e22b8e33b06aece11a944adef9532f5d79a37a97f3c7d4293db6
pkgname = task-maker-git
diff --git a/PKGBUILD b/PKGBUILD
index 8b225f92be17..bdb410eb3a01 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,18 @@
# Co-maintainer: Edoardo Morassutto <edoardo.morassutto@gmail.com>
pkgname=task-maker-git
-pkgver=r378.bcb4240
+pkgver=r504.34e4020
pkgrel=1
pkgdesc="The new cmsMake!"
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
url="https://github.com/algorithm-ninja/task-maker"
license=('MPL2')
-depends=('python' 'libyaml')
-makedepends=('bazel')
+depends=('python' 'protobuf' 'grpc')
+makedepends=('cmake' 'gmock' 'gtest' 'cli11' 'nlohmann-json' 'plog' 'python-pip')
provides=('task-maker')
conflicts=('task-maker')
-source=("git+https://github.com/algorithm-ninja/task-maker.git"
- "launcher")
-sha384sums=('SKIP'
- '28377283ca07a411f1283e8067a30903a4726f66f765e22b8e33b06aece11a944adef9532f5d79a37a97f3c7d4293db6')
+source=("git+https://github.com/algorithm-ninja/task-maker.git")
+sha384sums=('SKIP')
pkgver() {
cd "$srcdir/task-maker"
@@ -24,20 +22,13 @@ pkgver() {
build() {
cd "$srcdir/task-maker"
- export PYTHON_BIN_PATH=/usr/bin/python
- export USE_DEFAULT_PYTHON_LIB_PATH=1
- mkdir -p tmp
- bazel --output_base=./tmp build --python_path=python3 -c opt //python:task_maker
+ rm -rf build && mkdir -p build
+ cd build
+ cmake -DHUNTER_ENABLED=OFF -DCMAKE_BUILD_TYPE=Release ..
+ make
}
package() {
- mkdir -p "$pkgdir/opt/task-maker-git/"
- mkdir -p "$pkgdir/usr/bin/"
- cp "$srcdir/launcher" "$pkgdir/usr/bin/task-maker"
- cd "$srcdir/task-maker"
- cd bazel-bin/python
- for f in $(find -type l); do
- cp --remove-destination "$(readlink "$f")" "$f"
- done
- cp -r task_maker* "$pkgdir/opt/task-maker-git/"
+ cd "$srcdir/task-maker/build/python"
+ python setup.py install --root="$pkgdir/" --optimize=1
}
diff --git a/launcher b/launcher
deleted file mode 100755
index 521c8fe36f95..000000000000
--- a/launcher
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/bash
-
-/opt/task-maker-git/task_maker "$@"