summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2018-08-01 15:59:22 -0400
committerJean Lucas2018-08-01 15:59:22 -0400
commit2836637d704ba86722d0eec0e69563d4ae8cca52 (patch)
tree4ad5aadbab49a22cd3ff5914bf69bb7de2518586
downloadaur-2836637d704ba86722d0eec0e69563d4ae8cca52.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD33
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..16240a3b808c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Wed Aug 1 19:59:07 UTC 2018
+pkgbase = taskbook-git
+ pkgdesc = Tasks, boards & notes for the command-line habitat (git)
+ pkgver = 0.1.1+2+g9cc92e8
+ pkgrel = 1
+ url = https://github.com/klauscfhq/taskbook
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = npm
+ depends = nodejs
+ provides = taskbook
+ conflicts = taskbook
+ source = git+https://github.com/klauscfhq/taskbook
+ sha512sums = SKIP
+
+pkgname = taskbook-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..590a90115238
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Jean Lucas <jean@4ray.co>
+
+pkgname=taskbook-git
+pkgver=0.1.1+2+g9cc92e8
+pkgrel=1
+pkgdesc='Tasks, boards & notes for the command-line habitat (git)'
+arch=(any)
+url=https://github.com/klauscfhq/taskbook
+license=(MIT)
+depends=(nodejs)
+makedepends=(git npm)
+provides=(taskbook)
+conflicts=(taskbook)
+source=(git+$url)
+sha512sums=(SKIP)
+
+pkgver() {
+ cd taskbook
+ git describe --tags | sed 's/v//;s/-/+/g'
+}
+
+build() {
+ cd taskbook
+ npm install
+}
+
+package() {
+ install -d "$pkgdir"/usr/{lib/node_modules,bin}
+ cp -a taskbook "$pkgdir"/usr/lib/node_modules
+ chmod +x "$pkgdir"/usr/lib/node_modules/taskbook/cli.js
+ ln -s /usr/lib/node_modules/taskbook/cli.js "$pkgdir"/usr/bin/taskbook
+ install -Dm 644 taskbook/license.md "$pkgdir"/usr/share/licenses/taskbook/LICENSE
+}