summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Rys2022-08-21 20:40:19 +0200
committerMartin Rys2022-08-21 20:40:19 +0200
commit6cfeedcd941691a934d5b8386ccd5e6eec23a014 (patch)
treee20f9389abaeba7e8362ec07b4962390917420bb
parent19ad1ccba2f6b0e9deafb080233a680360e2a307 (diff)
downloadaur-taskfile-git.tar.gz
Fix the completions conflict with community/task
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 30947c4fc23d..7f64bbdf5104 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = taskfile-git
pkgdesc = A task runner / simpler Make alternative written in Go
pkgver = 3.14.1.r12.g97d4a94
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/go-task/task
arch = any
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index d030eb71d9ad..abe56fc08b9e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=taskfile-git
_pkgname=task
pkgver=3.14.1.r12.g97d4a94
-pkgrel=2
+pkgrel=3
pkgdesc="A task runner / simpler Make alternative written in Go"
arch=('any')
license=('MIT')
@@ -34,7 +34,10 @@ package() {
find "$srcdir/go/bin/" -type f -executable | while read filename; do
install -DT "$filename" "$pkgdir/usr/bin/$(basename $filename)"
done
+ # Avoid conflicts with community/task
mv "${pkgdir}/usr/bin/task" "${pkgdir}/usr/bin/task-go"
+ install -DT "$srcdir/${_pkgname}/completion/zsh/_task" "${pkgdir}/usr/share/zsh/site-functions/_task-go"
- install -DT "$srcdir/$_pkgname/completion/zsh/_task" "$pkgdir/usr/share/zsh/site-functions/_task"
+ # TODO I suppose fish and ps completion files would also be nice to installa
+ install -DT "$srcdir/${_pkgname}/completion/bash/task.bash" "${pkgdir}/usr/share/bash-completion/completions/go-task"
}