summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlanpn2021-04-15 11:07:23 +0700
committerlanpn2021-04-15 11:07:23 +0700
commit05825bf8e67a966e398fc15278dc4fa1af1b244d (patch)
treef062ea14bece198b647e63b3512cbe524977eda9
downloadaur-05825bf8e67a966e398fc15278dc4fa1af1b244d.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD51
-rw-r--r--install.sh31
4 files changed, 104 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0785153aa4e7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = taskflow-git
+ pkgdesc = Simple resource-aware task scheduler
+ pkgver = r39.1354414
+ pkgrel = 1
+ url = https://github.com/lanPN85/taskflow
+ install = install.sh
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = python-virtualenv
+ makedepends = binutils
+ depends = zlib
+ source = git+https://github.com/lanPN85/taskflow#tag=0.1.0
+ md5sums = SKIP
+
+pkgname = taskflow-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a0deb92d9627
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+.vscode/
+taskflow/
+src/
+pkg/
+*.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2b2e53f088eb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Lan Phan <phan.ngoclan58[at]gmail[dot]com>
+
+pkgname=taskflow-git
+pkgver=r39.1354414
+pkgrel=1
+pkgdesc="Simple resource-aware task scheduler"
+arch=('x86_64')
+url="https://github.com/lanPN85/taskflow"
+license=('GPL3')
+groups=()
+depends=('zlib')
+makedepends=('git' 'python-virtualenv' 'binutils')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install='install.sh'
+source=('git+https://github.com/lanPN85/taskflow#tag=0.1.0')
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/taskflow"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/taskflow"
+}
+
+build() {
+ cd "$srcdir/taskflow"
+ test -f "venv" || virtualenv venv/
+ . venv/bin/activate
+ pip install -r requirements.txt
+ pip install -r requirements.dev.txt
+ make build
+}
+
+check() {
+ cd "$srcdir/taskflow"
+}
+
+package() {
+ cd "$srcdir/taskflow"
+ make DESTDIR="$pkgdir" install
+ mkdir -p "$pkgdir/usr/lib/systemd/system"
+ cp etc/taskflowd.service "$pkgdir/usr/lib/systemd/system/taskflowd.service"
+}
diff --git a/install.sh b/install.sh
new file mode 100644
index 000000000000..d12ca9c547cc
--- /dev/null
+++ b/install.sh
@@ -0,0 +1,31 @@
+## arg 1: the new package version
+#pre_install() {
+ # do something here
+#}
+
+## arg 1: the new package version
+# post_install() {
+
+# }
+
+## arg 1: the new package version
+## arg 2: the old package version
+#pre_upgrade() {
+ # do something here
+#}
+
+## arg 1: the new package version
+## arg 2: the old package version
+#post_upgrade() {
+ # do something here
+#}
+
+## arg 1: the old package version
+#pre_remove() {
+ # do something here
+#}
+
+## arg 1: the old package version
+#post_remove() {
+ # do something here
+#}