summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Schlatow2022-06-04 11:35:43 +0200
committerJohannes Schlatow2022-06-04 11:35:43 +0200
commit454bc3a6fde662c453c9eb8891b2ba2368affcb6 (patch)
tree01e3ff09975a95d8edc69ab8861145d22ac20987
parente38284cfcfb02f117b3f295cf675e27382220d9e (diff)
downloadaur-454bc3a6fde662c453c9eb8891b2ba2368affcb6.tar.gz
Update version
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 590cf0400bac..34c3167ad507 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,16 @@
pkgbase = taskopen
pkgdesc = Script for taking notes and open urls with taskwarrior
- pkgver = 1.1.5
+ pkgver = 2.0.0beta
pkgrel = 1
- url = http://github.com/ValiValpas/taskopen/
+ url = http://github.com/jschlatow/taskopen/
arch = i686
arch = x86_64
license = GPL
- makedepends = git
makedepends = make
- depends = perl
- depends = perl-json
- depends = task>=2.4.0
+ makedepends = nim
+ depends = task>=2.5.0
optdepends = xdg-utils: easily use default application associated with a file type
- source = https://codeload.github.com/ValiValpas/taskopen/tar.gz/v1.1.5
- sha256sums = edf9dc76dd70089e3334bac27fddf24450fc4385d0dc3089d7ecc983d19c977c
+ source = https://codeload.github.com/jschlatow/taskopen/tar.gz/v2.0.0beta
+ sha256sums = 2487cc132118041b9a49a4ff956caedfa6ec70d93d3cd903601de166e2d0246a
pkgname = taskopen
diff --git a/PKGBUILD b/PKGBUILD
index 7f810c0e6948..bdafae6ceb58 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Johannes Schlatow <johannes.schlatow@googlemail.com>
pkgname=taskopen
-pkgver=1.1.5
+pkgver=2.0.0beta
pkgrel=1
pkgdesc="Script for taking notes and open urls with taskwarrior"
arch=('i686' 'x86_64')
-url="http://github.com/ValiValpas/taskopen/"
+url="http://github.com/jschlatow/taskopen/"
license=('GPL')
-depends=('perl' 'perl-json' 'task>=2.4.0')
+depends=('task>=2.5.0')
optdepends=('xdg-utils: easily use default application associated with a file type')
-makedepends=('git' 'make')
-source=("https://codeload.github.com/ValiValpas/taskopen/tar.gz/v${pkgver}")
-sha256sums=("edf9dc76dd70089e3334bac27fddf24450fc4385d0dc3089d7ecc983d19c977c")
+makedepends=('make' 'nim')
+source=("https://codeload.github.com/jschlatow/taskopen/tar.gz/v${pkgver}")
+sha256sums=("2487cc132118041b9a49a4ff956caedfa6ec70d93d3cd903601de166e2d0246a")
build() {
cd "$srcdir/${pkgname}-${pkgver}"
@@ -23,4 +23,6 @@ package() {
cd "$srcdir/${pkgname}-${pkgver}"
make DESTDIR="$pkgdir" PREFIX="/usr" install
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}