summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeander Harding2015-12-07 16:02:28 -0800
committerLeander Harding2015-12-07 16:02:28 -0800
commit61a218b998e94b17d378102fdf4d756d16bd0b18 (patch)
treedf7b4679d17a99a2a63b1d8a92fb2f2d74527c41
parentd341f42021b7f3acfa10b49a486a13ce4221a9fc (diff)
downloadaur-61a218b998e94b17d378102fdf4d756d16bd0b18.tar.gz
Maintainer change, fixed build.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
-rw-r--r--tasknc-build_fix.patch13
-rw-r--r--tasknc-emptyfilter_fix.patch19
-rw-r--r--tasknc-man_cleanup.patch79
-rw-r--r--tasknc-sync_fix.patch13
6 files changed, 12 insertions, 157 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4bd6bd856b85..98022fea622b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,10 @@
+# Generated by mksrcinfo v8
+# Tue Dec 8 00:01:34 UTC 2015
pkgbase = taskwarrior-tasknc-git
pkgdesc = a ncurses wrapper around taskwarrior
- pkgver = 20151030.r547.7aa81f2
+ pkgver = 20151122.r615.b887688
pkgrel = 1
- url = https://github.com/mjheagle8/tasknc
+ url = https://github.com/lharding/tasknc
arch = i686
arch = x86_64
arch = arm
@@ -16,16 +18,8 @@ pkgbase = taskwarrior-tasknc-git
provides = tasknc-git
conflicts = tasknc-git
replaces = tasknc-git
- source = git://github.com/mjheagle8/tasknc.git#branch=master
- source = tasknc-build_fix.patch
- source = tasknc-sync_fix.patch
- source = tasknc-man_cleanup.patch
- source = tasknc-emptyfilter_fix.patch
+ source = git://github.com/lharding/tasknc.git#branch=master
sha512sums = SKIP
- sha512sums = b0297b2526b9bbef296f0a67f0209bfe85fd15f714701534f29ed85cd7da5bd3ca16d6457ee2859ee074b8ccf2db73cf46eb492c89953bac91d4778f823cb3cc
- sha512sums = af3d5cd6e6277b5be1b50bfbe4549c0db195f8a1a7dd07285140448326a380674331fb3e283b84fe992150d428d0200d2c9376342137f356b7edfcaf150fd8aa
- sha512sums = 5dfeb7c7732c9490010b22628e8012414c3dd96ecb98540d826b306cc1b4731b2055bdb180e012534ec642b19fbd735ad9782cb43ea39381f662c38aa777bdfe
- sha512sums = f105652d6235d77a277105c92097d9f552c1bb988cdc72c621bb2264b60b97ff3fcf50ed967467ca06f50fd7120007cee232e3dfb021a373cb09f38340e082b2
pkgname = taskwarrior-tasknc-git
diff --git a/PKGBUILD b/PKGBUILD
index 6d4c30262b24..8b252fdf752b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
-# Maintainer: Kevin MacMartin <prurigro at gmail dot com>
+# Maintainer: Leander Harding <lsh at lsh dot io>
_pkgname=tasknc
pkgname=taskwarrior-${_pkgname}-git
-pkgver=20151030.r547.7aa81f2
+pkgver=20151122.r615.b887688
pkgrel=1
pkgdesc="a ncurses wrapper around taskwarrior"
-url="https://github.com/mjheagle8/${_pkgname}"
+url="https://github.com/lharding/${_pkgname}"
license=('GPL3')
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
depends=('task' 'perl')
@@ -13,16 +13,8 @@ makedepends=('git' 'cmake')
replaces=("${_pkgname}-git")
conflicts=("${_pkgname}-git")
provides=("${_pkgname}-git")
-source=("git://github.com/mjheagle8/${_pkgname}.git#branch=master"
- "${_pkgname}-build_fix.patch"
- "${_pkgname}-sync_fix.patch"
- "${_pkgname}-man_cleanup.patch"
- "${_pkgname}-emptyfilter_fix.patch")
-sha512sums=('SKIP'
- 'b0297b2526b9bbef296f0a67f0209bfe85fd15f714701534f29ed85cd7da5bd3ca16d6457ee2859ee074b8ccf2db73cf46eb492c89953bac91d4778f823cb3cc'
- 'af3d5cd6e6277b5be1b50bfbe4549c0db195f8a1a7dd07285140448326a380674331fb3e283b84fe992150d428d0200d2c9376342137f356b7edfcaf150fd8aa'
- '5dfeb7c7732c9490010b22628e8012414c3dd96ecb98540d826b306cc1b4731b2055bdb180e012534ec642b19fbd735ad9782cb43ea39381f662c38aa777bdfe'
- 'f105652d6235d77a277105c92097d9f552c1bb988cdc72c621bb2264b60b97ff3fcf50ed967467ca06f50fd7120007cee232e3dfb021a373cb09f38340e082b2')
+source=("git://github.com/lharding/${_pkgname}.git#branch=master")
+sha512sums=('SKIP')
pkgver() {
cd $_pkgname
@@ -31,21 +23,14 @@ pkgver() {
prepare() {
cd $_pkgname
- patch -p1 < ../${_pkgname}-build_fix.patch
- patch -p1 < ../${_pkgname}-sync_fix.patch
- patch -p1 < ../${_pkgname}-man_cleanup.patch
- patch -p1 < ../${_pkgname}-emptyfilter_fix.patch
}
build() {
cd $_pkgname
- mkdir build
- cd build
- cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr ..
make
}
package() {
- cd ${_pkgname}/build
- make DESTDIR="$pkgdir" install
+ cd $_pkgname
+ make PREFIX="/usr" DESTDIR="$pkgdir" install
}
diff --git a/tasknc-build_fix.patch b/tasknc-build_fix.patch
deleted file mode 100644
index 6abf6426de71..000000000000
--- a/tasknc-build_fix.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
-index e89ccf1..89fdbc5 100644
---- a/doc/CMakeLists.txt
-+++ b/doc/CMakeLists.txt
-@@ -4,7 +4,7 @@ SET(OUT_MANPAGE tasknc.1)
- ADD_CUSTOM_COMMAND(
- TARGET ManPages
- SOURCE ${CMAKE_CURRENT_SOURCE_DIR}/${IN_POD}
-- COMMAND pod2man ARGS -s 1 --section=1 --center="tasknc Manual" --name="tasknc" --release="tasknc ${VERSION}" ${CMAKE_CURRENT_SOURCE_DIR}/${IN_POD}
-+ COMMAND pod2man ARGS --errors=none -s 1 --section=1 --center="tasknc Manual" --name="tasknc" --release="tasknc ${VERSION}" ${CMAKE_CURRENT_SOURCE_DIR}/${IN_POD}
- ${CMAKE_CURRENT_BINARY_DIR}/${OUT_MANPAGE}
- OUTPUTS ${CMAKE_CURRENT_BINARY_DIR}/${OUT_MANPAGE}
- )
diff --git a/tasknc-emptyfilter_fix.patch b/tasknc-emptyfilter_fix.patch
deleted file mode 100644
index e8474af11977..000000000000
--- a/tasknc-emptyfilter_fix.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-diff --git a/src/tasklist.c b/src/tasklist.c
-index 0c106c0..b392076 100644
---- a/src/tasklist.c
-+++ b/src/tasklist.c
-@@ -475,8 +475,12 @@ void tasklist_window() /* {{{ */
- /* check for an empty task list */
- if (head == NULL)
- {
-- tnc_fprintf(logfp, LOG_ERROR, "it appears that your task list is empty. %s does not yet support empty task lists.", PROGNAME);
-- ncurses_end(-1);
-+ if (strcmp(active_filter,"") == 0){
-+ tnc_fprintf(logfp, LOG_ERROR, "it appears that your task list is empty. %s does not yet support empty task lists.", PROGNAME);
-+ ncurses_end(-1);
-+ }
-+ active_filter = strdup("");
-+ reload = true;
- }
-
- /* get the screen size */
diff --git a/tasknc-man_cleanup.patch b/tasknc-man_cleanup.patch
deleted file mode 100644
index 71e216ae2fea..000000000000
--- a/tasknc-man_cleanup.patch
+++ /dev/null
@@ -1,79 +0,0 @@
-diff --git a/doc/manual.pod b/doc/manual.pod
-index 3903e28..c97ae3f 100644
---- a/doc/manual.pod
-+++ b/doc/manual.pod
-@@ -105,7 +105,7 @@ resort list (prompted for sort order)
-
- =item B<y>
-
--synchronize (run task merge and task push)
-+synchronize (run task sync)
-
- =item B<q>
-
-@@ -131,7 +131,7 @@ open command prompt
-
- =head1 CONFIGURATION
-
--tasknc honors a config file located at
-+tasknc honors a config file located at
-
- $XDG_CONFIG_HOME/tasknc/config
-
-@@ -157,7 +157,9 @@ Commands are either supplied at the command prompt or listed in the configuratio
-
- =item
-
--=item B<color> I<object> I<foreground> I<background> I<rule> assign an I<object> to be a color when I<rule> is satisfied. Only task I<object>s evaluate I<rule>s. The following objects are available:
-+=item B<color> I<object> I<foreground> I<background> I<rule> assign an I<object> to be a color when I<rule> is satisfied. Only task I<object>s evaluate I<rule>s.
-+
-+The following objects are available:
-
- =over 4
-
-@@ -169,7 +171,11 @@ Commands are either supplied at the command prompt or listed in the configuratio
-
- =back
-
--=item Colors are specified in one of three formats:
-+=item
-+
-+=item
-+
-+Colors are specified in one of three formats:
-
- =over 4
-
-@@ -181,7 +187,11 @@ Commands are either supplied at the command prompt or listed in the configuratio
-
- =back
-
--=item Rules are specified in the following format: ~I<pattern> I<arg>. Pattern is a single character; if lowercase it indicates a positive match, and if uppercase it indicates a negative match. Regular expression arguments must be enclosed in single quotes. The following patterns are available:
-+=item
-+
-+=item Rules are specified in the following format: ~I<pattern> I<arg>. Pattern is a single character; if lowercase it indicates a positive match, and if uppercase it indicates a negative match. Regular expression arguments must be enclosed in single quotes.
-+
-+The following patterns are available:
-
- =over 4
-
-@@ -289,7 +299,9 @@ Commands are either supplied at the command prompt or listed in the configuratio
-
- =item
-
--=item B<sort> I<optarg> applies a sort defined by string I<optarg> or prompts user for sort mode with no arg. The sort string defines the priority of each sort component. Tasks will first be compared by the first character's order, if they are equal, the next characters sort order will be evaluated. The default sort order is due, priority, project, uuid (notated drpu). Capitalized characters indicate invert the sort for that field. The following characters are valid sorts:
-+=item B<sort> I<optarg> applies a sort defined by string I<optarg> or prompts user for sort mode with no arg. The sort string defines the priority of each sort component. Tasks will first be compared by the first character's order, if they are equal, the next characters sort order will be evaluated. The default sort order is due, priority, project, uuid (notated drpu). Capitalized characters indicate invert the sort for that field.
-+
-+The following characters are valid sorts:
-
- =over 4
-
-@@ -319,7 +331,7 @@ Commands are either supplied at the command prompt or listed in the configuratio
-
- =item
-
--=item B<sync> runs 'task merge && task push'.
-+=item B<sync> runs 'task sync'.
-
- =item
-
diff --git a/tasknc-sync_fix.patch b/tasknc-sync_fix.patch
deleted file mode 100644
index 3499b0fb390f..000000000000
--- a/tasknc-sync_fix.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/tasklist.c b/src/tasklist.c
-index 3a5c323..0c106c0 100644
---- a/src/tasklist.c
-+++ b/src/tasklist.c
-@@ -308,7 +308,7 @@ void key_tasklist_sync() /* {{{ */
-
- statusbar_message(cfg.statusbar_timeout, "synchronizing tasks...");
-
-- ret = task_interactive_command("yes n | task merge && task push");
-+ ret = task_interactive_command("yes n | task sync");
-
- if (ret==0)
- {