summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM.Reynolds2019-10-14 13:39:35 -0400
committerM.Reynolds2019-10-14 13:39:35 -0400
commit40b7e401fae0005aa8000676d22b539077360716 (patch)
treeceec5e088867a561be40b03855584958f710224e
parente845b2935e46176497b01f6808bb460553ab3afb (diff)
downloadaur-40b7e401fae0005aa8000676d22b539077360716.tar.gz
Update 1.0.16-1 and modify desktop entry to set WM Class
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 404151ac6b57..d6de948777e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = tastyworks
pkgdesc = One of the fastest, most reliable, and most secure trading platforms in the world.
- pkgver = 1.0.15
+ pkgver = 1.0.16
pkgrel = 1
url = https://tastyworks.com/technology.html
arch = x86_64
license = Other
depends = java-runtime
- source = https://download.tastyworks.com/desktop-1.x.x/1.0.15/tastyworks-1.0.15-1.x86_64.rpm
+ source = https://download.tastyworks.com/desktop-1.x.x/1.0.16/tastyworks-1.0.16-1.x86_64.rpm
source = tastyworks.png
- sha256sums = 13cca9c54fe95461a83022b1149dbb6008c20109e805279c2a674872330dad98
+ sha256sums = 8a2c9bd54dd1736aa07e693839939988d94951537709cf1bd3e9263ce3368fd5
sha256sums = 5875675195bb9156c050976e00c98538a6662740f5359e677d26fe5e21560cea
pkgname = tastyworks
diff --git a/PKGBUILD b/PKGBUILD
index 818e1f71ecdc..4b4f78e8bd63 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: M.Reynolds <blackboxnetworkproject@gmail.com>
pkgname=tastyworks
-pkgver=1.0.15
+pkgver=1.0.16
pkgrel=1
pkgdesc="One of the fastest, most reliable, and most secure trading platforms in the world."
arch=('x86_64')
@@ -10,7 +10,7 @@ license=('Other')
depends=('java-runtime')
source=("https://download.tastyworks.com/desktop-1.x.x/$pkgver/$pkgname-$pkgver-$pkgrel.x86_64.rpm"
"tastyworks.png")
-sha256sums=('13cca9c54fe95461a83022b1149dbb6008c20109e805279c2a674872330dad98'
+sha256sums=('8a2c9bd54dd1736aa07e693839939988d94951537709cf1bd3e9263ce3368fd5'
'5875675195bb9156c050976e00c98538a6662740f5359e677d26fe5e21560cea')
package() {
@@ -33,10 +33,15 @@ package() {
sed -i 's|Icon=/opt/tastyworks/tastyworks.png|Icon=tastyworks|' "$srcdir/opt/$pkgname/bin/$pkgname.desktop"
sed -i 's|Categories=Unknown|Categories=Internet|' "$srcdir/opt/$pkgname/bin/$pkgname.desktop"
+ # Add the correct startup window manager class
+ # This *should* fix gnome from creating more than one dock entry for the program
+ echo 'StartupWMClass=tasty.javafx.launcher.LauncherFxApp' >> "$srcdir/opt/$pkgname/bin/$pkgname.desktop"
+ sed -i '/^[[:space:]]*$/d' "$srcdir/opt/$pkgname/bin/$pkgname.desktop"
+
install -Dm 644 "$srcdir/opt/$pkgname/bin/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
# Alternative Application Icon
install -Dm 644 "$srcdir/opt/$pkgname/bin/$pkgname.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
# install -Dm 644 "$pkgname.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
-} \ No newline at end of file
+}