summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM.Reynolds2018-08-12 01:21:54 -0400
committerM.Reynolds2018-08-12 01:21:54 -0400
commit88231a251540e954bceb219bf9c3766782b85f18 (patch)
tree981040a1a4fb105b98fcc2361f5bb02e161e5739
downloadaur-88231a251540e954bceb219bf9c3766782b85f18.tar.gz
Initial Package Upload
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e783701b418f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = tastyworks
+ pkgdesc = One of the fastest, most reliable, and most secure trading platforms in the world.
+ pkgver = 0.27.0
+ pkgrel = 1
+ url = https://tastyworks.com/technology.html
+ arch = x86_64
+ license = Other
+ depends = java-runtime
+ source = https://download.tastyworks.com/desktop/0.27.0/tastyworks-0.27.0.rpm
+ source = https://claytrader.com/wp-content/themes/ClayTrader/images/resources/tastyworks.png
+ sha256sums = 1e512ea67dc99f0a1108764c960a47e1f4e97ff51c7a62a386843611c22d1965
+ sha256sums = 0b566ce89d2030d2fe5e1aa2133c868e23da0c0accc3708b1960e2db7ebe7bcb
+
+pkgname = tastyworks
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..90f705d7b11e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: M.Reynolds <blackboxnetworkproject@gmail.com>
+
+pkgname=tastyworks
+pkgver=0.27.0
+pkgrel=1
+pkgdesc="One of the fastest, most reliable, and most secure trading platforms in the world."
+arch=('x86_64')
+url="https://tastyworks.com/technology.html"
+license=('Other')
+depends=('java-runtime')
+source=("https://download.tastyworks.com/desktop/$pkgver/$pkgname-$pkgver.rpm"
+ "https://claytrader.com/wp-content/themes/ClayTrader/images/resources/tastyworks.png")
+sha256sums=('1e512ea67dc99f0a1108764c960a47e1f4e97ff51c7a62a386843611c22d1965'
+ '0b566ce89d2030d2fe5e1aa2133c868e23da0c0accc3708b1960e2db7ebe7bcb')
+
+package() {
+
+ cd "$srcdir"
+
+ install -d "$pkgdir/opt/$pkgname"
+ cp -r "$srcdir/opt/$pkgname/" "$pkgdir/opt/"
+
+ sed -i 's|Name=tastyworks|Name=TastyWorks|' "$srcdir/opt/$pkgname/$pkgname.desktop"
+ sed -i 's|Comment=tastyworks|Comment=Trading Platform|' "$srcdir/opt/$pkgname/$pkgname.desktop"
+ sed -i 's|Categories=Unknown|Categories=Internet|' "$srcdir/opt/$pkgname/$pkgname.desktop"
+
+ install -Dm 644 "$srcdir/opt/$pkgname/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm 644 "$pkgname.png" "$pkgdir/opt/$pkgname/$pkgname.png"
+} \ No newline at end of file