summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2021-08-06 21:04:44 +0300
committerCaleb Maclennan2021-08-06 21:04:44 +0300
commit2fed85df6cc7453320b243e92e49ed0821a52582 (patch)
treea03021eb06f133b2fab13f0f04563d2ae9229c83
parent3925b55f8120be66bb046ae1323a6edc96d97e24 (diff)
downloadaur-2fed85df6cc7453320b243e92e49ed0821a52582.tar.gz
upgpkg: tau-editor 0.11.3-3
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD53
2 files changed, 32 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f45f0655a18f..7d66cc5b7a6a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,19 @@
pkgbase = tau-editor
pkgdesc = GTK frontend for the Xi text editor, written in Rust
pkgver = 0.11.3
- pkgrel = 2
- url = https://gitlab.gnome.org/World/tau
- arch = i686
+ pkgrel = 3
+ url = https://gitlab.gnome.org/World/Tau
arch = x86_64
+ arch = i686
arch = armv7h
arch = aarch64
license = MIT
- makedepends = git
makedepends = meson
makedepends = rust
- depends = xi-core
depends = libhandy0
depends = vte3
- provides = tau-editor
- conflicts = tau-editor
+ depends = xi-core
source = https://gitlab.gnome.org/World/Tau/uploads/b5f24cd692ec0c2a2c2be460fffaf505/tau-0.11.3.tar.xz
sha256sums = 36e915de4ca906599b4ad176d4e2d625b454801a09ca0d4b0a1fbaf14915e60e
pkgname = tau-editor
-
diff --git a/PKGBUILD b/PKGBUILD
index 7dffa9569e7a..eeeb7bdf8680 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,41 @@
-# Maintainer: Philip Goto <philip.goto@gmail.com>
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+# Contributor: Philip Goto <philip.goto@gmail.com>
+_pkgname=Tau
pkgname=tau-editor
pkgver=0.11.3
-pkgrel=2
-pkgdesc="GTK frontend for the Xi text editor, written in Rust"
-arch=(i686 x86_64 armv7h aarch64)
-url="https://gitlab.gnome.org/World/tau"
-license=('MIT')
-depends=(
- xi-core
- libhandy0
- vte3
-)
-makedepends=(
- git
- meson
- rust
-)
-provides=(tau-editor)
-conflicts=(tau-editor)
-source=("https://gitlab.gnome.org/World/Tau/uploads/b5f24cd692ec0c2a2c2be460fffaf505/tau-0.11.3.tar.xz")
+pkgrel=3
+pkgdesc='GTK frontend for the Xi text editor, written in Rust'
+arch=(x86_64 i686 armv7h aarch64)
+url="https://gitlab.gnome.org/World/$_pkgname"
+license=(MIT)
+depends=(libhandy0
+ vte3
+ xi-core)
+makedepends=(meson
+ rust)
+_archive="${_pkgname,,}-$pkgver"
+source=("$url/uploads/b5f24cd692ec0c2a2c2be460fffaf505/$_archive.tar.xz")
sha256sums=('36e915de4ca906599b4ad176d4e2d625b454801a09ca0d4b0a1fbaf14915e60e')
+prepare() {
+ cd "$_archive"
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
build() {
- arch-meson -Dxi-core=system -Dlibhandy=enabled "tau-${pkgver}" build
+ arch-meson \
+ -Dxi-core=system \
+ -Dlibhandy=enabled \
+ "$_archive" build
meson compile -C build
}
-# check() {
-# meson test -C build --print-errorlogs
-# }
+check() {
+ meson test -C build --print-errorlogs
+}
package() {
- DESTDIR="${pkgdir}" meson install -C build
- install -Dm 644 "tau-${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ DESTDIR="$pkgdir" meson install -C build
+ install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" "$_archive/LICENSE"
}