summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2021-01-05 23:59:24 +0100
committerPhilip Goto2021-01-05 23:59:24 +0100
commit3925b55f8120be66bb046ae1323a6edc96d97e24 (patch)
tree2ba2398c6bcffe1f831ff370bd0b07f5f3aac491
parent59fdfbeec7e8fd8dbfdb06a8447174c06fc5fd8a (diff)
downloadaur-3925b55f8120be66bb046ae1323a6edc96d97e24.tar.gz
Refactor PKGBUILD
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD34
2 files changed, 22 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5257b0f4322c..f45f0655a18f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = tau-editor
pkgdesc = GTK frontend for the Xi text editor, written in Rust
pkgver = 0.11.3
- pkgrel = 1
+ pkgrel = 2
url = https://gitlab.gnome.org/World/tau
arch = i686
arch = x86_64
- arch = armv6h
arch = armv7h
+ arch = aarch64
license = MIT
makedepends = git
makedepends = meson
makedepends = rust
depends = xi-core
- depends = libhandy
+ depends = libhandy0
depends = vte3
provides = tau-editor
conflicts = tau-editor
diff --git a/PKGBUILD b/PKGBUILD
index ff0373da9341..7dffa9569e7a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,33 +2,37 @@
pkgname=tau-editor
pkgver=0.11.3
-pkgrel=1
+pkgrel=2
pkgdesc="GTK frontend for the Xi text editor, written in Rust"
-arch=(i686 x86_64 armv6h armv7h)
+arch=(i686 x86_64 armv7h aarch64)
url="https://gitlab.gnome.org/World/tau"
license=('MIT')
-depends=('xi-core'
- 'libhandy'
- 'vte3')
-makedepends=('git'
- 'meson'
- 'rust')
-provides=("tau-editor")
-conflicts=("tau-editor")
+depends=(
+ xi-core
+ libhandy0
+ vte3
+)
+makedepends=(
+ git
+ meson
+ rust
+)
+provides=(tau-editor)
+conflicts=(tau-editor)
source=("https://gitlab.gnome.org/World/Tau/uploads/b5f24cd692ec0c2a2c2be460fffaf505/tau-0.11.3.tar.xz")
sha256sums=('36e915de4ca906599b4ad176d4e2d625b454801a09ca0d4b0a1fbaf14915e60e')
build() {
- arch-meson -Dxi-core=system -Dlibhandy=enabled "tau-${pkgver}" build
- ninja -C build
+ arch-meson -Dxi-core=system -Dlibhandy=enabled "tau-${pkgver}" build
+ meson compile -C build
}
# check() {
-# ninja -C build test
+# meson test -C build --print-errorlogs
# }
package() {
- DESTDIR="$pkgdir/" ninja -C build install
- install -Dm 644 "tau-${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ DESTDIR="${pkgdir}" meson install -C build
+ install -Dm 644 "tau-${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}