summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2020-01-03 20:59:38 +0100
committerPhilip Goto2020-01-03 20:59:38 +0100
commitcde8ad3e4b0cb2c41f744e9763891f55795cd8b0 (patch)
treecccbc81c9b9af88df072aaf83ae830ba5cb5c086
downloadaur-cde8ad3e4b0cb2c41f744e9763891f55795cd8b0.tar.gz
Initialize
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD33
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2a870f9395b0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = tau-editor
+ pkgdesc = GTK frontend for the Xi text editor, written in Rust
+ pkgver = 0.10.1
+ pkgrel = 1
+ url = https://gitlab.gnome.org/World/tau
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = MIT
+ makedepends = git
+ makedepends = meson
+ makedepends = rust
+ depends = xi-core
+ depends = libhandy
+ provides = tau-editor
+ conflicts = tau-editor
+ source = https://gitlab.gnome.org/World/Tau/uploads/25d33d736285ad451bc7b409aa01e957/tau-0.10.1.tar.xz
+ sha256sums = e97e848481e5a35ff6b9d5708e017c2d59a4d2ccc26fb5267fa0418ac060dc91
+
+pkgname = tau-editor
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ceea07c52bb1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Philip Goto <philip.goto@gmail.com>
+
+pkgname=tau-editor
+pkgver=0.10.1
+pkgrel=1
+pkgdesc="GTK frontend for the Xi text editor, written in Rust"
+arch=(i686 x86_64 armv6h armv7h)
+url="https://gitlab.gnome.org/World/tau"
+license=('MIT')
+depends=('xi-core'
+ 'libhandy')
+makedepends=('git'
+ 'meson'
+ 'rust')
+provides=("tau-editor")
+conflicts=("tau-editor")
+source=("https://gitlab.gnome.org/World/Tau/uploads/25d33d736285ad451bc7b409aa01e957/tau-0.10.1.tar.xz")
+sha256sums=('e97e848481e5a35ff6b9d5708e017c2d59a4d2ccc26fb5267fa0418ac060dc91')
+
+
+build() {
+ arch-meson -Dxi-core=system -Dlibhandy=enabled "tau-${pkgver}" build
+ ninja -C build
+}
+
+# check() {
+# ninja -C build test
+# }
+
+package() {
+ DESTDIR="$pkgdir/" ninja -C build install
+ install -Dm 644 "tau-${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}