summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuel Mesa2015-06-17 09:38:31 -0500
committerSamuel Mesa2015-06-17 09:38:31 -0500
commit8d53b34eaeb743a38cdbeee25c64caefd8c71699 (patch)
tree2abe3df3e5fb977df7c03d984abb47f719dd5c64
downloadaur-8d53b34eaeb743a38cdbeee25c64caefd8c71699.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD40
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7a4650ac4f7b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = taudem
+ pkgdesc = Suite of Digital Elevation Model (DEM) tools for the extraction and analysis of hydrologic information from topography as represented by a DEM
+ pkgver = 5.0.6
+ pkgrel = 2
+ url = http://hydrology.uwrl.usu.edu/taudem
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = openmpi
+ makedepends = cmake
+ options = !makeflags
+ source = http://hydrology.usu.edu/taudem/taudem5/TauDEM5PCsrc_506.zip
+ md5sums = 76848267b3acd1c4667b7c7d7112ade6
+
+pkgname = taudem
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b6c56e701608
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Samuel Mesa <samuelmesa at linuxmail.org>
+
+pkgname=taudem
+_pkgname=TauDEM
+pkgver=5.0.6
+pkgrel=2
+pkgdesc="Suite of Digital Elevation Model (DEM) tools for the extraction and analysis of hydrologic information from topography as represented by a DEM"
+arch=(i686 x86_64)
+url="http://hydrology.uwrl.usu.edu/taudem"
+license=('GPL')
+depends=()
+makedepends=('openmpi' 'cmake')
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+options=('!makeflags')
+source=(http://hydrology.usu.edu/taudem/taudem5/TauDEM5PCsrc_506.zip)
+md5sums=('76848267b3acd1c4667b7c7d7112ade6')
+
+build() {
+ unzip ${_pkgname}5PCsrc_506.zip
+ cd src
+ sed -i -e '40 a #include <stdint.h>' ./linearpart.h
+ find . -type f -name "*.cpp" -o -name "*.h" | xargs sed -i 's/#include "stdint.h"/#include <stdint.h>/'
+
+ rm -rf build
+ mkdir build
+ cd build
+
+ msg "starting make..."
+ CXX=mpicxx cmake .. -DCMAKE_INSTALL_PREFIX=/usr/local
+ make all
+}
+
+package() {
+ cd "$srcdir/"src/build
+ make DESTDIR=${pkgdir} install
+}
+