summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTaiko2k2020-08-25 13:45:09 +1200
committerTaiko2k2020-08-25 13:45:09 +1200
commit60edf016a887b404b1dd43124c770b1512764419 (patch)
treeb892e92ef088082d4a7f0cd3e190fcd2bf520893
parent036878914429c3fe4eb39f9bf28c51a138f75b56 (diff)
downloadaur-60edf016a887b404b1dd43124c770b1512764419.tar.gz
rewrite pkgbuild
-rw-r--r--.SRCINFO52
-rw-r--r--PKGBUILD87
2 files changed, 83 insertions, 56 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ea53078c04f3..e74ee937c3a5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,52 +1,46 @@
pkgbase = tauon-music-box
pkgdesc = A modern streamlined music player
pkgver = 6.2.1
- pkgrel = 1
- url = https://github.com/taiko2k/tauonmb
+ pkgrel = 2
+ url = https://tauonmusicbox.rocks
arch = any
license = GPL3
- depends = python3
- depends = noto-fonts
- depends = noto-fonts-extra
- depends = sdl2_image
depends = python-pillow
depends = python-pylast
+ depends = python-flask
+ depends = python-hsaudiotag3k
+ depends = python-pysdl2
+ depends = python-stagger
+ depends = python-send2trash
+ depends = python-pylyrics
+ depends = python-musicbrainzngs
+ depends = python-discogs-client
+ depends = python-isounidecode
+ depends = python-setproctitle
depends = python-gobject
- depends = xdg-utils
+ depends = python-cairo
depends = python-beautifulsoup4
depends = python-requests
- depends = python-cairo
- depends = python-flask
- depends = python-setproctitle
- depends = flac
- depends = python-musicbrainzngs
- depends = alsa-plugins
- depends = gstreamer
- depends = gst-plugins-base
depends = python-dbus
depends = python-oauthlib
depends = python-six
- depends = gst-plugins-good
+ depends = alsa-plugins
+ depends = ffmpeg
+ depends = flac
depends = gst-plugins-bad
depends = gst-plugins-ugly
+ depends = noto-fonts-extra
depends = noto-fonts-cjk
- depends = python-discogs-client
- depends = python-hsaudiotag3k
- depends = python-pylyrics
- depends = python-pypresence
- depends = python-send2trash
- depends = python-stagger
- depends = python-pysdl2
- depends = ffmpeg
+ depends = sdl2_image
+ depends = xdg-utils
optdepends = p7zip: 7z archive extraction support
optdepends = unrar: RAR archive extraction support
- optdepends = python-plexapi: PLEX streaming
+ optdepends = python-plexapi: Plex streaming
+ optdepends = python-pypresence: Discord status support
optdepends = python-tekore: Spotify playback control
optdepends = picard: Tag editing
- source = git+https://github.com/Taiko2k/TauonMusicBox.git#tag=v6.2.1
- source = https://files.pythonhosted.org/packages/1e/d3/1491ad4be5f67d89ad83c9fd751f5d6b83d052c1a8ddd994f37ae37b0d9d/isounidecode-0.3.tar.gz
- sha256sums = SKIP
- sha256sums = 4db0a962c6341826c9a69acaabc2f923a5b124d53a335be892ef29173bc31c5b
+ source = tauon-music-box-6.2.1.tar.gz::https://github.com/Taiko2k/TauonMusicBox/archive/v6.2.1.tar.gz
+ sha256sums = 90ac549dd86467dfeeb1bb9a5282bc08f48300294b6466a8902e2f18fd381873
pkgname = tauon-music-box
diff --git a/PKGBUILD b/PKGBUILD
index 78100e1d7da8..a1f6aa27ec95 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,72 @@
-
# Maintainer: Taiko2k <captain dot gxj at gmail dot com>
-pkgname='tauon-music-box'
-pkgdesc='A modern streamlined music player'
-url="https://github.com/taiko2k/tauonmb"
-gitname='TauonMusicBox'
+pkgname=tauon-music-box
+_pkgname=tauonmb
+_gitname=TauonMusicBox
+pkgver=6.2.1
+pkgrel=2
+pkgdesc="A modern streamlined music player"
arch=('any')
+url="https://tauonmusicbox.rocks"
license=('GPL3')
-pkgver=6.2.1
-pkgrel=1
-
-depends=('python3' 'noto-fonts' 'noto-fonts-extra' 'sdl2_image' 'python-pillow' 'python-pylast' 'python-gobject' 'xdg-utils' 'python-beautifulsoup4' 'python-requests' 'python-cairo' 'python-flask' 'python-setproctitle' 'flac' 'python-musicbrainzngs' 'alsa-plugins' 'gstreamer' 'gst-plugins-base' 'python-dbus' 'python-oauthlib' 'python-six' 'gst-plugins-good' 'gst-plugins-bad' 'gst-plugins-ugly' 'noto-fonts-cjk' 'python-discogs-client' 'python-hsaudiotag3k' 'python-pylyrics' 'python-pypresence' 'python-send2trash' 'python-stagger' 'python-pysdl2' 'ffmpeg')
-
-optdepends=('p7zip: 7z archive extraction support' 'unrar: RAR archive extraction support' 'python-plexapi: PLEX streaming' 'python-tekore: Spotify playback control' 'picard: Tag editing')
-
-source=("git+https://github.com/Taiko2k/TauonMusicBox.git#tag=v$pkgver" "https://files.pythonhosted.org/packages/1e/d3/1491ad4be5f67d89ad83c9fd751f5d6b83d052c1a8ddd994f37ae37b0d9d/isounidecode-0.3.tar.gz")
-
-sha256sums=("SKIP" "4db0a962c6341826c9a69acaabc2f923a5b124d53a335be892ef29173bc31c5b")
-
+depends=('python-pillow'
+ 'python-pylast'
+ 'python-flask'
+ 'python-hsaudiotag3k'
+ 'python-pysdl2' # AUR
+ 'python-stagger' # AUR
+ 'python-send2trash'
+ 'python-pylyrics' # AUR
+ 'python-musicbrainzngs'
+ 'python-discogs-client'
+ 'python-isounidecode' # AUR
+ 'python-setproctitle'
+ 'python-gobject'
+ 'python-cairo'
+ 'python-beautifulsoup4'
+ 'python-requests'
+ 'python-dbus'
+ 'python-oauthlib'
+ 'python-six'
+ 'alsa-plugins'
+ 'ffmpeg'
+ 'flac'
+ 'gst-plugins-bad'
+ 'gst-plugins-ugly'
+ 'noto-fonts-extra'
+ 'noto-fonts-cjk'
+ 'sdl2_image'
+ 'xdg-utils')
+
+optdepends=('p7zip: 7z archive extraction support'
+ 'unrar: RAR archive extraction support'
+ 'python-plexapi: Plex streaming'
+ 'python-pypresence: Discord status support'
+ 'python-tekore: Spotify playback control'
+ 'picard: Tag editing')
+
+source=("$pkgname-$pkgver.tar.gz::https://github.com/Taiko2k/TauonMusicBox/archive/v$pkgver.tar.gz")
+sha256sums=('90ac549dd86467dfeeb1bb9a5282bc08f48300294b6466a8902e2f18fd381873')
build() {
- cd $gitname
+ cd "$_gitname-$pkgver"
python compile-translations.py
}
package() {
-
- install -dm755 "$pkgdir/opt/$pkgname/isounidecode"
- cp -r "$srcdir/isounidecode-0.3/isounidecode/." "$pkgdir/opt/$pkgname/isounidecode"
- cp -r "$srcdir/$gitname/." "$pkgdir/opt/$pkgname"
- install -D -m755 "$srcdir/$gitname/extra/tauonmb.desktop" "$pkgdir/usr/share/applications/tauonmb.desktop"
- install -D -m755 "$srcdir/$gitname/extra/tauonmb-symbolic.svg" "$pkgdir/usr/share/icons/hicolor/scalable/apps/tauonmb-symbolic.svg"
- install -D -m755 "$srcdir/$gitname/extra/tauonmb.svg" "$pkgdir/usr/share/icons/hicolor/scalable/apps/tauonmb.svg"
- install -D -m755 "$srcdir/$gitname/extra/tauonmb.sh" "$pkgdir/opt/$pkgname/tauonmb.sh"
- install -D -m755 "$srcdir/$gitname/extra/tauonmb.sh" "$pkgdir/usr/bin/tauon"
- }
+ cd "$_gitname-$pkgver"
+ install -Dm755 tauon.py -t "$pkgdir/opt/$pkgname"
+ install -d "$pkgdir/usr/bin"
+ ln -s "/opt/$pkgname/tauon.py" "$pkgdir/usr/bin/$_pkgname"
+
+ install -Dm644 input.txt -t "$pkgdir/opt/$pkgname"
+ cp -r locale assets templates theme t_modules "$pkgdir/opt/$pkgname"
+
+ install -Dm644 "extra/$_pkgname.desktop" -t "$pkgdir/usr/share/applications"
+ install -Dm644 "extra/$_pkgname-symbolic.svg" -t "$pkgdir/usr/share/icons/hicolor/symbolic/apps"
+ install -Dm644 "extra/$_pkgname.svg" -t "$pkgdir/usr/share/icons/hicolor/scalable/apps"
+ install -Dm755 "extra/tauonmb.sh" "$pkgdir/opt/$pkgname/tauonmb.sh"
+ install -Dm755 "extra/tauonmb.sh" "$pkgdir/usr/bin/tauon"
+}