summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTaiko2k2020-07-05 21:33:45 +1200
committerTaiko2k2020-07-05 21:33:45 +1200
commitc7e071a155053842d78e3d2a8d3d7bbf29b326fb (patch)
treed43eb9f89a9f7fa29c4f3a0967b1cfda59157103
parentd07de1d9e4aec3603ff3140221b3565b17ee1e80 (diff)
downloadaur-c7e071a155053842d78e3d2a8d3d7bbf29b326fb.tar.gz
update for v6.0.0
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD9
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6e14b7bd972f..81450a460d92 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tauon-music-box
pkgdesc = A modern streamlined music player
- pkgver = 5.5.5
+ pkgver = 6.0.0
pkgrel = 1
url = https://github.com/taiko2k/tauonmb
arch = any
@@ -33,10 +33,11 @@ pkgbase = tauon-music-box
optdepends = ffmpeg: File transcoding
optdepends = p7zip: 7z archive extraction support
optdepends = unrar: RAR archive extraction support
- optdepends = python-plexapi: PLEX client streaming
+ optdepends = python-plexapi: PLEX streaming
+ optdepends = python-tekore: Spotify playback control
optdepends = picard: Tag editing
- source = https://github.com/Taiko2k/tauonmb/releases/download/v5.5.5/Tauon.Music.Box.v5.5.5.Linux.zip
- sha1sums = cc0c4d07857f69777b544732d8d6679ef02d451d
+ source = https://github.com/Taiko2k/tauonmb/releases/download/v6.0.0/Tauon.Music.Box.v6.0.0.Linux.zip
+ sha1sums = 1e2fde321454a02721d3bd59ec820e76d4c7831f
pkgname = tauon-music-box
diff --git a/PKGBUILD b/PKGBUILD
index bca3dfb5d314..5fd42378dcd5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,16 +7,16 @@ url="https://github.com/taiko2k/tauonmb"
arch=('any')
license=('GPL3')
-pkgver=5.5.5
+pkgver=6.0.0
pkgrel=1
depends=('python3' 'noto-fonts' 'noto-fonts-extra' 'sdl2_image' 'python-pillow' 'python-pylast' 'python-gobject' 'xdg-utils' 'python-beautifulsoup4' 'python-requests' 'python-cairo' 'python-flask' 'python-setproctitle' 'flac' 'python-musicbrainzngs' 'alsa-plugins' 'gstreamer' 'gst-plugins-base' 'python-dbus' 'python-oauthlib' 'python-six' 'gst-plugins-good' 'gst-plugins-bad' 'gst-plugins-ugly' 'noto-fonts-cjk')
-optdepends=('ffmpeg: File transcoding' 'p7zip: 7z archive extraction support' 'unrar: RAR archive extraction support' 'python-plexapi: PLEX client streaming' 'picard: Tag editing')
+optdepends=('ffmpeg: File transcoding' 'p7zip: 7z archive extraction support' 'unrar: RAR archive extraction support' 'python-plexapi: PLEX streaming' 'python-tekore: Spotify playback control' 'picard: Tag editing')
-source=('https://github.com/Taiko2k/tauonmb/releases/download/v5.5.5/Tauon.Music.Box.v5.5.5.Linux.zip')
+source=('https://github.com/Taiko2k/tauonmb/releases/download/v6.0.0/Tauon.Music.Box.v6.0.0.Linux.zip')
-sha1sums=('cc0c4d07857f69777b544732d8d6679ef02d451d')
+sha1sums=('1e2fde321454a02721d3bd59ec820e76d4c7831f')
package() {
@@ -29,6 +29,7 @@ package() {
cp -R "$srcdir/$pkgname/" "$pkgdir/opt/$pkgname"
install -D -m755 "$srcdir/$pkgname/extra/tauonmb.sh" "$pkgdir/opt/$pkgname/tauonmb.sh"
+ install -D -m755 "$srcdir/$pkgname/extra/tauonmb.sh" "$pkgdir/usr/bin/tauon"
}