summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorphyskets2018-12-10 12:59:42 +0530
committerphyskets2018-12-10 12:59:42 +0530
commitd8270cb95fc19c26b1b5e4e86d50882f75aec336 (patch)
treeb56d8d52fd1b15be377c55d4b1cc524ed91e58ec
downloadaur-d8270cb95fc19c26b1b5e4e86d50882f75aec336.tar.gz
initial
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d6324dba6aec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = tbftss-the-pandoran-war
+ pkgdesc = A 2D mission-based space shooter, based on the Battle for the Solar System space opera novel trilogy.
+ pkgver = 1.4.0
+ pkgrel = 1
+ url = https://www.battleforthesolarsystem.com/
+ arch = x86_64
+ license = GPL2
+ depends = sdl2
+ depends = sdl2_image
+ depends = sdl2_mixer
+ depends = sdl2_ttf
+ source = tbftss-1.4.0.tar.gz::https://github.com/stephenjsweeney/tbftss/archive/v1.4.0.tar.gz
+ sha256sums = c8c128f89253a04cfc91a01a2c25fad6b0804df0bc28505c703335cb7a37331f
+
+pkgname = tbftss-the-pandoran-war
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cbbb610982cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: physkets <physkets // at // tutanota dot com>
+_pkgname=tbftss
+pkgname=${_pkgname}-the-pandoran-war
+pkgver=1.4.0
+pkgrel=1
+pkgdesc="A 2D mission-based space shooter, based on the Battle for the Solar System space opera novel trilogy."
+url="https://www.battleforthesolarsystem.com/"
+arch=('x86_64')
+license=('GPL2')
+depends=('sdl2' 'sdl2_image' 'sdl2_mixer' 'sdl2_ttf')
+source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/stephenjsweeney/${_pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('c8c128f89253a04cfc91a01a2c25fad6b0804df0bc28505c703335cb7a37331f')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim:set ts=2 sw=2 et: