summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorphyskets2018-12-10 14:41:34 +0530
committerphyskets2018-12-10 14:41:34 +0530
commit657f0010e97677d8c246c157b4deb8d67af84ae6 (patch)
tree87cae2ec3309f37fa79f49b0051d20e864e3bf4b
parentcac1aa49f206a03785084067563236fd2126c011 (diff)
downloadaur-657f0010e97677d8c246c157b4deb8d67af84ae6.tar.gz
fix source rename
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7ae74076dc91..93aac7f1b496 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,7 +9,7 @@ pkgbase = tbftss-the-pandoran-war-git
depends = sdl2_image
depends = sdl2_mixer
depends = sdl2_ttf
- source = tbftss-r1619.5ed5b6b.tar.gz::git+https://github.com/stephenjsweeney/tbftss#branch=develop
+ source = tbftss-git::git+https://github.com/stephenjsweeney/tbftss#branch=develop
sha256sums = SKIP
pkgname = tbftss-the-pandoran-war-git
diff --git a/PKGBUILD b/PKGBUILD
index 2a34a24119bb..084d2b5936a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,21 +8,21 @@ url="https://www.battleforthesolarsystem.com/"
arch=('x86_64')
license=('GPL2')
depends=('sdl2' 'sdl2_image' 'sdl2_mixer' 'sdl2_ttf')
-source=("${_pkgname}-${pkgver}.tar.gz::git+https://github.com/stephenjsweeney/${_pkgname}#branch=develop")
+source=("${_pkgname}-git::git+https://github.com/stephenjsweeney/${_pkgname}#branch=develop")
sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd "${srcdir}/${_pkgname}-git"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd "${srcdir}/${_pkgname}-git"
make
}
package() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd "${srcdir}/${_pkgname}-git"
make DESTDIR="${pkgdir}" install
}