summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorphyskets2018-12-10 14:30:28 +0530
committerphyskets2018-12-10 14:30:28 +0530
commit779bb465f8f1daa8d1516b620e9ba3d421aae422 (patch)
tree0bf4d5b4642665114c2f2ebdd76b60b345b25012
downloadaur-779bb465f8f1daa8d1516b620e9ba3d421aae422.tar.gz
inital
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7ae74076dc91
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = tbftss-the-pandoran-war-git
+ pkgdesc = A 2D mission-based space shooter, based on the Battle for the Solar System space opera novel trilogy.
+ pkgver = r1619.5ed5b6b
+ pkgrel = 1
+ url = https://www.battleforthesolarsystem.com/
+ arch = x86_64
+ license = GPL2
+ depends = sdl2
+ depends = sdl2_image
+ depends = sdl2_mixer
+ depends = sdl2_ttf
+ source = tbftss-r1619.5ed5b6b.tar.gz::git+https://github.com/stephenjsweeney/tbftss#branch=develop
+ sha256sums = SKIP
+
+pkgname = tbftss-the-pandoran-war-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7a8638b0dc29
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: physkets <physkets // at // tutanota dot com>
+_pkgname=tbftss
+pkgname=${_pkgname}-the-pandoran-war-git
+pkgver="r1619.5ed5b6b"
+pkgrel=1
+pkgdesc="A 2D mission-based space shooter, based on the Battle for the Solar System space opera novel trilogy."
+url="https://www.battleforthesolarsystem.com/"
+arch=('x86_64')
+license=('GPL2')
+depends=('sdl2' 'sdl2_image' 'sdl2_mixer' 'sdl2_ttf')
+source=("${_pkgname}-${pkgver}.tar.gz::git+https://github.com/stephenjsweeney/${_pkgname}#branch=develop")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim:set ts=2 sw=2 et: