summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmiliano Deustua2021-03-14 19:00:34 -0400
committerEmiliano Deustua2021-03-14 19:00:34 -0400
commit860a3809ac38d4d758f16341a6521ee30c002d39 (patch)
treeb4281d0d43873f89a69d955855d93f81346cb225
downloadaur-860a3809ac38d4d758f16341a6521ee30c002d39.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD42
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..db0c00963d55
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = tblis-git
+ pkgdesc = TBLIS is a library and framework for performing tensor operations, especially tensor contraction, using efficient native algorithms.
+ pkgver = v1.2.0.r17.g3dd4acb
+ pkgrel = 1
+ url = https://github.com/devinamatthews/tblis
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ makedepends = gcc
+ makedepends = openblas
+ provides = tblis
+ options = staticlibs
+ options = libtool
+ source = tblis::git+https://github.com/devinamatthews/tblis.git
+ sha256sums = SKIP
+
+pkgname = tblis-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dee123b6d171
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: J. Emiliano Deustua <edeustua@gmail.com>
+
+pkgname=tblis-git
+_pkgname=tblis
+pkgver=v1.2.0.r17.g3dd4acb
+pkgrel=1
+pkgdesc="TBLIS is a library and framework for performing tensor operations, especially tensor contraction, using efficient native algorithms."
+arch=('x86_64')
+url="https://github.com/devinamatthews/tblis"
+license=('BSD')
+options=(staticlibs libtool)
+makedepends=('git' 'gcc' 'openblas')
+provides=('tblis')
+source=("$_pkgname::git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$_pkgname"
+
+ "./configure" \
+ --prefix=/usr \
+ --enable-thread-model=openmp \
+ --enable-config=auto \
+ --with-blas="-lopenblas"
+
+ make
+}
+
+check() {
+ ./$_pkgname/bin/test
+}
+
+package() {
+ cd "$_pkgname"
+ make DESTDIR="$pkgdir" install
+}
+