summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXiao-Long Chen2016-01-20 00:42:11 -0500
committerXiao-Long Chen2016-01-20 00:42:11 -0500
commit1945f0cb9a3b4507b3d8413fbc7cc7961f2177c1 (patch)
tree81ad80e0845a18acdeb24b86c46bbdbd3ccc457e
parenta6c217461dbc3e84ca43bfb260d60668a9e3afb3 (diff)
downloadaur-1945f0cb9a3b4507b3d8413fbc7cc7961f2177c1.tar.gz
Fix installation and GRUB issues pointed out by jasonritzke
-rw-r--r--.SRCINFO8
-rw-r--r--0001-Install-to-usr-bin-instead-of-usr-sbin.patch104
-rw-r--r--0002-20_linux_tboot-Remove-check-for-boot-config-which-do.patch26
-rw-r--r--PKGBUILD17
4 files changed, 151 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7bfc704f4b7d..d1a5ebeb49df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,20 @@
+# Generated by mksrcinfo v8
+# Wed Jan 20 05:41:42 UTC 2016
pkgbase = tboot
pkgdesc = A pre-kernel/VMM module that uses Intel(R) TXT to perform a measured and verified launch of an OS kernel/VMM.
pkgver = 1.8.3
- pkgrel = 1
+ pkgrel = 2
url = http://sourceforge.net/projects/tboot/
arch = i686
arch = x86_64
license = BSD
depends = trousers
source = http://downloads.sourceforge.net/project/tboot/tboot/tboot-1.8.3.tar.gz
+ source = 0001-Install-to-usr-bin-instead-of-usr-sbin.patch
+ source = 0002-20_linux_tboot-Remove-check-for-boot-config-which-do.patch
sha512sums = cde961af07c64a7d8b77f64d48e6d9230048135420e78efc6277f32e4df78012b5bbd73e4f2ce1cd6194091ec306cc84c65356865815a7311e140fd2b94f6443
+ sha512sums = b3777a871c7ae09566dcdd4f14d5f8f3a097d2c321f5eb7c2e561594837718c3c31bc70a28a3cb342e0888724176eeccd2d73e204a6cddb245f4017b84433d30
+ sha512sums = aaec2527587211a5ab07f98ff0c8bbe20c32df09752a7364215625b665337c8ee4c582a06639d36b64dfd78e87974d6bd722df140b268280a539d6492942e87c
pkgname = tboot
diff --git a/0001-Install-to-usr-bin-instead-of-usr-sbin.patch b/0001-Install-to-usr-bin-instead-of-usr-sbin.patch
new file mode 100644
index 000000000000..e157d2ae478e
--- /dev/null
+++ b/0001-Install-to-usr-bin-instead-of-usr-sbin.patch
@@ -0,0 +1,104 @@
+From fecab57fed659f020872112d2123c89c2e7f0f22 Mon Sep 17 00:00:00 2001
+From: Xiao-Long Chen <chenxiaolong@cxl.epac.to>
+Date: Wed, 20 Jan 2016 00:37:02 -0500
+Subject: [PATCH 1/2] Install to /usr/bin instead of /usr/sbin
+
+---
+ lcptools-v2/Makefile | 6 +++---
+ lcptools/Makefile | 6 +++---
+ tb_polgen/Makefile | 8 ++++----
+ utils/Makefile | 6 +++---
+ 4 files changed, 13 insertions(+), 13 deletions(-)
+
+diff --git a/lcptools-v2/Makefile b/lcptools-v2/Makefile
+index d6c4626..6fa9bff 100644
+--- a/lcptools-v2/Makefile
++++ b/lcptools-v2/Makefile
+@@ -34,15 +34,15 @@ dist : install
+ install :
+ @set -e; for i in $(LCP2_TARGETS);\
+ do \
+- $(MAKE) DISTDIR=$(DISTDIR) INST_TARGET=$(DISTDIR)/usr/sbin/$$i do_install; \
++ $(MAKE) DISTDIR=$(DISTDIR) INST_TARGET=$(DISTDIR)/usr/bin/$$i do_install; \
+ done
+
+ .PHONY: do_install
+ do_install : $(INST_TARGET)
+
+ $(INST_TARGET) : $(notdir $(INST_TARGET))
+- [ -d $(DISTDIR)/usr/sbin ] || $(INSTALL_DIR) $(DISTDIR)/usr/sbin
+- $(INSTALL_PROG) -t $(DISTDIR)/usr/sbin $^
++ [ -d $(DISTDIR)/usr/bin ] || $(INSTALL_DIR) $(DISTDIR)/usr/bin
++ $(INSTALL_PROG) -t $(DISTDIR)/usr/bin $^
+
+
+ clean :
+diff --git a/lcptools/Makefile b/lcptools/Makefile
+index f4d8bd4..a20324a 100644
+--- a/lcptools/Makefile
++++ b/lcptools/Makefile
+@@ -50,15 +50,15 @@ dist : install
+ install :
+ @set -e; for i in $(TPMNV_TARGETS) $(LCP1_TARGETS) $(LCP2_TARGETS);\
+ do \
+- $(MAKE) DISTDIR=$(DISTDIR) INST_TARGET=$(DISTDIR)/usr/sbin/$$i do_install; \
++ $(MAKE) DISTDIR=$(DISTDIR) INST_TARGET=$(DISTDIR)/usr/bin/$$i do_install; \
+ done
+
+ .PHONY: do_install
+ do_install : $(INST_TARGET)
+
+ $(INST_TARGET) : $(notdir $(INST_TARGET))
+- [ -d $(DISTDIR)/usr/sbin ] || $(INSTALL_DIR) $(DISTDIR)/usr/sbin
+- $(INSTALL_PROG) -t $(DISTDIR)/usr/sbin $^
++ [ -d $(DISTDIR)/usr/bin ] || $(INSTALL_DIR) $(DISTDIR)/usr/bin
++ $(INSTALL_PROG) -t $(DISTDIR)/usr/bin $^
+
+
+ clean :
+diff --git a/tb_polgen/Makefile b/tb_polgen/Makefile
+index 6a76717..3298005 100644
+--- a/tb_polgen/Makefile
++++ b/tb_polgen/Makefile
+@@ -29,11 +29,11 @@ build : $(TARGET)
+ dist : install
+
+
+-install : $(DISTDIR)/usr/sbin/$(TARGET)
++install : $(DISTDIR)/usr/bin/$(TARGET)
+
+-$(DISTDIR)/usr/sbin/$(TARGET) : $(TARGET)
+- [ -d $(DISTDIR)/usr/sbin ] || $(INSTALL_DIR) $(DISTDIR)/usr/sbin
+- $(INSTALL_PROG) -t $(DISTDIR)/usr/sbin $(TARGET)
++$(DISTDIR)/usr/bin/$(TARGET) : $(TARGET)
++ [ -d $(DISTDIR)/usr/bin ] || $(INSTALL_DIR) $(DISTDIR)/usr/bin
++ $(INSTALL_PROG) -t $(DISTDIR)/usr/bin $(TARGET)
+
+
+ clean :
+diff --git a/utils/Makefile b/utils/Makefile
+index 8650bcc..8ec00e2 100644
+--- a/utils/Makefile
++++ b/utils/Makefile
+@@ -27,15 +27,15 @@ dist : install
+ install :
+ @set -e; for i in $(TARGETS);\
+ do \
+- $(MAKE) DISTDIR=$(DISTDIR) INST_TARGET=$(DISTDIR)/usr/sbin/$$i do_install; \
++ $(MAKE) DISTDIR=$(DISTDIR) INST_TARGET=$(DISTDIR)/usr/bin/$$i do_install; \
+ done
+
+ .PHONY: do_install
+ do_install : $(INST_TARGET)
+
+ $(INST_TARGET) : $(notdir $(INST_TARGET))
+- [ -d $(DISTDIR)/usr/sbin ] || $(INSTALL_DIR) $(DISTDIR)/usr/sbin
+- $(INSTALL_PROG) -t $(DISTDIR)/usr/sbin $^
++ [ -d $(DISTDIR)/usr/bin ] || $(INSTALL_DIR) $(DISTDIR)/usr/bin
++ $(INSTALL_PROG) -t $(DISTDIR)/usr/bin $^
+
+
+ clean :
+--
+2.7.0
+
diff --git a/0002-20_linux_tboot-Remove-check-for-boot-config-which-do.patch b/0002-20_linux_tboot-Remove-check-for-boot-config-which-do.patch
new file mode 100644
index 000000000000..517495780fb8
--- /dev/null
+++ b/0002-20_linux_tboot-Remove-check-for-boot-config-which-do.patch
@@ -0,0 +1,26 @@
+From cd4bf89b3f70e8e2e983a2eda50e434e0c7a1227 Mon Sep 17 00:00:00 2001
+From: Xiao-Long Chen <chenxiaolong@cxl.epac.to>
+Date: Wed, 20 Jan 2016 00:38:58 -0500
+Subject: [PATCH 2/2] 20_linux_tboot: Remove check for /boot/config-*, which
+ does not exist
+
+---
+ tboot/20_linux_tboot | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tboot/20_linux_tboot b/tboot/20_linux_tboot
+index 6f8cfee..ce59ab9 100644
+--- a/tboot/20_linux_tboot
++++ b/tboot/20_linux_tboot
+@@ -124,7 +124,7 @@ EOF
+ linux_list=`for i in /boot/vmlinu[xz]-* /vmlinu[xz]-* ; do
+ basename=$(basename $i)
+ version=$(echo $basename | sed -e "s,^[^0-9]*-,,g")
+- if grub_file_is_not_garbage "$i" && grep -qx "CONFIG_INTEL_TXT=y" /boot/config-${version} 2> /dev/null ; then echo -n "$i " ; fi
++ if grub_file_is_not_garbage "$i" ; then echo -n "$i " ; fi
+ done`
+ tboot_list=`for i in /boot/tboot*.gz; do
+ if grub_file_is_not_garbage "$i" ; then echo -n "$i " ; fi
+--
+2.7.0
+
diff --git a/PKGBUILD b/PKGBUILD
index 6680cb2a7407..b116ccbdfefa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,25 @@
pkgname=tboot
pkgver=1.8.3
-pkgrel=1
+pkgrel=2
pkgdesc="A pre-kernel/VMM module that uses Intel(R) TXT to perform a measured and verified launch of an OS kernel/VMM."
arch=(i686 x86_64)
url="http://sourceforge.net/projects/tboot/"
license=(BSD)
depends=(trousers)
-source=("http://downloads.sourceforge.net/project/${pkgname}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
-sha512sums=('cde961af07c64a7d8b77f64d48e6d9230048135420e78efc6277f32e4df78012b5bbd73e4f2ce1cd6194091ec306cc84c65356865815a7311e140fd2b94f6443')
+source=("http://downloads.sourceforge.net/project/${pkgname}/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+ 0001-Install-to-usr-bin-instead-of-usr-sbin.patch
+ 0002-20_linux_tboot-Remove-check-for-boot-config-which-do.patch)
+sha512sums=('cde961af07c64a7d8b77f64d48e6d9230048135420e78efc6277f32e4df78012b5bbd73e4f2ce1cd6194091ec306cc84c65356865815a7311e140fd2b94f6443'
+ 'b3777a871c7ae09566dcdd4f14d5f8f3a097d2c321f5eb7c2e561594837718c3c31bc70a28a3cb342e0888724176eeccd2d73e204a6cddb245f4017b84433d30'
+ 'aaec2527587211a5ab07f98ff0c8bbe20c32df09752a7364215625b665337c8ee4c582a06639d36b64dfd78e87974d6bd722df140b268280a539d6492942e87c')
+
+prepare() {
+ cd "${pkgname}-${pkgver}"
+
+ patch -p1 -i ../0001-Install-to-usr-bin-instead-of-usr-sbin.patch
+ patch -p1 -i ../0002-20_linux_tboot-Remove-check-for-boot-config-which-do.patch
+}
build() {
cd "${pkgname}-${pkgver}"