summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederik Schwan2020-05-17 04:51:13 +0200
committerFrederik Schwan2020-05-17 04:51:13 +0200
commitd45efe38b660263892caf13401956e084e4a2735 (patch)
tree4799916530b650028a6672edff6cf1275b1dca0a
parent9f93495fd9e117762f03d4a5b450b509a148bec2 (diff)
downloadaur-d45efe38b660263892caf13401956e084e4a2735.tar.gz
review by anthraxx
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD18
2 files changed, 10 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 68a9ec373a38..bccd6940ee92 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tbt
pkgdesc = Thunderbolt(TM) user-space components
pkgver = 0.9.3
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/01org/thunderbolt-software-user-space
arch = x86_64
license = BSD
@@ -9,7 +9,7 @@ pkgbase = tbt
makedepends = boost
makedepends = txt2tags
depends = boost-libs
- source = https://github.com/01org/thunderbolt-software-user-space/archive/v0.9.3.tar.gz
+ source = https://github.com/01org/thunderbolt-software-user-space/archive/v0.9.3/tbt-0.9.3.tar.gz
b2sums = afc614d0d2f7de3c23988e08c0053d24a04be51d22986497e3863b76ad59f1a8a9e2ab323210df27a3fa2f07ab05122666a3c6bfde146250f0854b2dfb6748f8
pkgname = tbt
diff --git a/PKGBUILD b/PKGBUILD
index 078429b2454a..5cfe44069d5d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,32 +2,30 @@
pkgname=tbt
pkgver=0.9.3
-pkgrel=2
+pkgrel=3
pkgdesc='Thunderbolt(TM) user-space components'
arch=('x86_64')
url='https://github.com/01org/thunderbolt-software-user-space'
license=('BSD')
depends=('boost-libs')
makedepends=('cmake' 'boost' 'txt2tags')
-source=("https://github.com/01org/thunderbolt-software-user-space/archive/v${pkgver}.tar.gz")
+source=("https://github.com/01org/thunderbolt-software-user-space/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz")
b2sums=('afc614d0d2f7de3c23988e08c0053d24a04be51d22986497e3863b76ad59f1a8a9e2ab323210df27a3fa2f07ab05122666a3c6bfde146250f0854b2dfb6748f8')
prepare() {
- mkdir -p thunderbolt-software-user-space-${pkgver}/build
+ cd thunderbolt-software-user-space-${pkgver}
+ cmake -B build -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DUDEV_BIN_DIR=/usr/lib/udev/ \
+ -DUDEV_RULES_DIR=/usr/lib/udev/rules.d/
}
build() {
cd thunderbolt-software-user-space-${pkgver}/build
- cmake .. -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DUDEV_BIN_DIR=/usr/lib/udev/ \
- -DUDEV_RULES_DIR=/usr/lib/udev/rules.d/
- cmake --build .
+ make
}
package() {
cd thunderbolt-software-user-space-${pkgver}/build
make DESTDIR="${pkgdir}" install
-
- rm -rf "${pkgdir}"/usr/share/doc
}