summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwangzhichao2022-09-23 14:49:55 +0800
committerwangzhichao2022-09-23 14:49:55 +0800
commit32990c69109ac5332672849cee1999b68c20a5b0 (patch)
tree09ddb336e3b71f8d71643ca972c07ba71380b62f
downloadaur-32990c69109ac5332672849cee1999b68c20a5b0.tar.gz
first commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
-rw-r--r--TBtools.desktop9
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..66928a86a878
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = tbtools
+ pkgdesc = GUI/CommandLine Tool Box for biologistists to utilize NGS data.
+ pkgver = 1.098769
+ pkgrel = 1
+ url = https://github.com/CJ-Chen/TBtools
+ arch = x86_64
+ license = custom:commercial
+ depends = java-runtime>=1.8
+ depends = bash
+ options = !strip
+ source = TBtools-1.098769.zip::https://github.com/CJ-Chen/TBtools/archive/refs/tags/1.098769.zip
+ source = TBtools.desktop
+ sha256sums = c38bd398e590ca8437fa8267e669c86cdcda541f867cbc8da8b1c61f60b55a90
+ sha256sums = 3c12fbf52a0e3fb96fe62302f6b3938e8e42a393468620091ca7d9259073af13
+
+pkgname = tbtools
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd1074d6a614
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: wangzhichao <wangzhichao1990@126.com>
+pkgname=tbtools
+_pkgname=TBtools
+pkgver=1.098769
+pkgrel=1
+pkgdesc='GUI/CommandLine Tool Box for biologistists to utilize NGS data. '
+arch=('x86_64')
+license=('custom:commercial')
+depends=('java-runtime>=1.8' 'bash')
+url='https://github.com/CJ-Chen/TBtools'
+source=("${_pkgname}-${pkgver}.zip::https://github.com/CJ-Chen/TBtools/archive/refs/tags/1.098769.zip"
+ "${_pkgname}.desktop"
+)
+sha256sums=(
+ 'c38bd398e590ca8437fa8267e669c86cdcda541f867cbc8da8b1c61f60b55a90'
+ '3c12fbf52a0e3fb96fe62302f6b3938e8e42a393468620091ca7d9259073af13'
+)
+options=(!strip)
+
+package() {
+ mkdir -p ${pkgdir}/opt/${_pkgname}/
+ unzip ${srcdir}/${_pkgname}-${pkgver}/TBtools_JRE1.6.jar
+ install -Dm755 ${srcdir}/${_pkgname}-${pkgver}/Linux.sh ${pkgdir}/opt/${_pkgname}/
+ install -Dm755 ${srcdir}/${_pkgname}-${pkgver}/TBtools_JRE1.6.jar ${pkgdir}/opt/${_pkgname}/
+ install -Dm644 ${srcdir}/Icons/TBtoolsLogo.png ${pkgdir}/opt/${_pkgname}/TBtoolsLogo.png
+ install -Dm644 ${srcdir}/${_pkgname}.desktop ${pkgdir}/usr/share/applications/${_pkgname}.desktop
+}
+
diff --git a/TBtools.desktop b/TBtools.desktop
new file mode 100644
index 000000000000..133c59e58894
--- /dev/null
+++ b/TBtools.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=TBtools
+Comment=GUI/CommandLine Tool Box for biologistists to utilize NGS data.
+GenericName=TBtools
+Terminal=false
+Icon=/opt/TBtools/TBtoolsLogo.png
+Type=Application
+Exec=/opt/TBtools/Linux.sh
+Categories=Education;Science;