summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLorens Gwine2017-11-30 12:50:08 +0500
committerLorens Gwine2017-11-30 12:50:08 +0500
commit80e624141f4520f1be76a13ef8c21eebec14ba66 (patch)
tree909c9e36d2ca6b27a289bc9264369ad44a13d6cd
parentcad5ffe48e74e6c5565bf46bb79e87fabd8f06c1 (diff)
downloadaur-80e624141f4520f1be76a13ef8c21eebec14ba66.tar.gz
add icons and .desktop
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
-rw-r--r--tc-twitch.desktop8
3 files changed, 18 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a34a0ee619f2..9c8d7ec62fb9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,7 +9,9 @@ pkgbase = tc-twitch-git
makedepends = npm
provides = tc-twitch
conflicts = tc-twitch
+ source = tc-twitch.desktop
source = tc-twitch-git::git+https://github.com/mccxiv/tc.git
+ md5sums = 72e3fe4d7076cd6e7c26d5d3819b1c0a
md5sums = SKIP
pkgname = tc-twitch-git
diff --git a/PKGBUILD b/PKGBUILD
index 28ef85866634..3fcc09ab4ffd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,8 +11,9 @@ license=('custom')
provides=($_pkgname)
conflicts=($_pkgname)
makedepends=('git' 'npm')
-source=("$pkgname::git+https://github.com/mccxiv/tc.git")
-md5sums=('SKIP')
+source=("$_pkgname.desktop" "$pkgname::git+https://github.com/mccxiv/tc.git")
+md5sums=('72e3fe4d7076cd6e7c26d5d3819b1c0a'
+ 'SKIP')
pkgver() {
cd $pkgname
@@ -38,5 +39,9 @@ package() {
install -d "$pkgdir"/{usr/bin,opt}
cp -a $srcdir/$pkgname/dist/linux-unpacked $pkgdir/opt/$_pkgname
ln -s $pkgdit/opt/$_pkgname/Tc $pkgdir/usr/bin/tc-twitch
- install -Dm644 $srcdir/$pkgname/LICENSE "$pkgdir"/usr/share/licenses/$_pkgname/LICENSE
+ install -Dm644 $srcdir/$_pkgname.desktop $pkgdir/usr/share/applications/$_pkgname.desktop
+ install -Dm644 $srcdir/$pkgname/LICENSE $pkgdir/usr/share/licenses/$_pkgname/LICENSE
+ # icons
+ install -Dm644 $srcdir/$pkgname/src/assets/icon16.png $pkgdir/usr/share/icons/hicolor/16x16/apps/$_pkgname.png
+ install -Dm644 $srcdir/$pkgname/src/assets/icon256.png $pkgdir/usr/share/icons/hicolor/256x256/apps/$_pkgname.png
}
diff --git a/tc-twitch.desktop b/tc-twitch.desktop
new file mode 100644
index 000000000000..cd563e2cb111
--- /dev/null
+++ b/tc-twitch.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Tc
+Comment=The chat client for Twitchâ„¢
+Exec=tc-twitch
+Icon=tc-twitch
+Terminal=false
+Type=Application
+Categories=Network;InstantMessaging;