summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornoprobelm2023-12-29 11:55:04 -0500
committernoprobelm2023-12-29 11:55:04 -0500
commit04cfaadc789e5feba740dc91d026db288ca545df (patch)
tree24a3bba1a61b9dcd8d7989bee0c11faefff73757
downloadaur-04cfaadc789e5feba740dc91d026db288ca545df.tar.gz
First commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD39
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6acc05db7c05
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = tca
+ pkgdesc = Simulate cellular automaton and render it to the terminal
+ pkgver = 0.1.0.r140.f8d6106
+ pkgrel = 1
+ url = https://github.com/noprobelm/terminal-cellular-automaton.git
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ makedepends = python-poetry-core
+ depends = python-rich
+ depends = python-requests
+ provides = tca
+ source = tca::git+https://github.com/noprobelm/terminal-cellular-automaton.git
+ md5sums = SKIP
+
+pkgname = tca
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9dfe750133d4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: noprobelm@protonmail.com
+pkgname=tca
+pkgver=0.1.0.r140.f8d6106
+pkgrel=1
+pkgdesc="Simulate cellular automaton and render it to the terminal"
+arch=(any)
+url="https://github.com/noprobelm/terminal-cellular-automaton.git"
+license=('MIT')
+groups=()
+depends=(python-rich python-requests)
+makedepends=(git python-setuptools python-build python-installer python-wheel python-poetry-core)
+optdepends=()
+provides=(tca)
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("$pkgname"::"git+$url")
+noextract=()
+md5sums=('SKIP') #autofill using updpkgsums
+
+pkgver() {
+ cd "$pkgname"
+ printf "0.1.0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd tca
+ /usr/bin/python3 -m build --wheel --no-isolation
+}
+
+package() {
+ cd tca
+ python -m installer --destdir="$pkgdir" --compile-bytecode=2 dist/*.whl
+ install -Dm 644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm 644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
+}