summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornrio2015-09-12 21:57:25 +0200
committernrio2015-09-12 21:57:25 +0200
commit573bd6e861d21f0d65257349ee2a090cb041d7cf (patch)
tree58afbfa306aba64f808aa399d12ed7435ad41fb5
downloadaur-573bd6e861d21f0d65257349ee2a090cb041d7cf.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD23
-rw-r--r--tcharmap_start4
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ce56223dc684
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = tcharmap-git
+ pkgdesc = Overview of unicode characters and their LaTeX counterpart
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/nrio0/tcharmap.git
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python
+ depends = python-yaml
+ depends = python-pyqt5
+ options = !emptydirs
+ source = git+https://github.com/nrio0/tcharmap.git
+ source = tcharmap_start
+ sha256sums = SKIP
+ sha256sums = 5b72ad0b095beb7c8becb647b2f2cc054e0bb4f476bce66cf2d33af907dec4e5
+
+pkgname = tcharmap-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..39de2c065746
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: nrio <nrio@mailbox.org>
+pkgname=tcharmap-git
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="Overview of unicode characters and their LaTeX counterpart"
+arch=('any')
+url="https://github.com/nrio0/tcharmap.git"
+license=('MIT')
+options=(!emptydirs)
+depends=('python' 'python-yaml' 'python-pyqt5')
+makedepends=('git' 'python-setuptools')
+source=('git+https://github.com/nrio0/tcharmap.git'
+ 'tcharmap_start')
+sha256sums=('SKIP'
+ '5b72ad0b095beb7c8becb647b2f2cc054e0bb4f476bce66cf2d33af907dec4e5')
+
+
+package() {
+ install -Dm755 "$srcdir/tcharmap_start" "$pkgdir/usr/bin/tcharmap"
+ cd "$srcdir/${pkgname%-git}"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname-%git}/LICENSE"
+}
diff --git a/tcharmap_start b/tcharmap_start
new file mode 100644
index 000000000000..b8f53bfb23e7
--- /dev/null
+++ b/tcharmap_start
@@ -0,0 +1,4 @@
+#!/usr/bin/env python
+
+from tcharmap import tcharmap
+tcharmap.main()