summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorColin Keenan2015-06-19 11:20:42 -0700
committerColin Keenan2015-06-19 11:20:42 -0700
commit8df163b3e42f6c244c93e710f4ddf627473eb9f4 (patch)
tree647972b4fd9db186bebe047b67405fa318d4e693
parent551e9b1c4da4aae422ade559f8235a65911b9a2c (diff)
downloadaur-8df163b3e42f6c244c93e710f4ddf627473eb9f4.tar.gz
Update to 1.3_1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD9
-rw-r--r--tchrome.install4
3 files changed, 16 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a60ae6612856..f5229c21b385 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
pkgbase = tchrome
pkgdesc = Close Chrome browser including background, or launch a version of Google Chrome/Chromium
- pkgver = 1.2
+ pkgver = 1.3
pkgrel = 1
url = https://github.com/colinkeenan/tchrome
install = tchrome.install
arch = any
license = GPL
- source = https://raw.githubusercontent.com/colinkeenan/tchrome/v1.2/tchrome
- source = https://raw.githubusercontent.com/colinkeenan/tchrome/v1.2/tchrome.conf
- source = https://raw.githubusercontent.com/colinkeenan/tchrome/v1.2/tchrome.desktop
+ source = https://raw.githubusercontent.com/colinkeenan/tchrome/v1.3/tchrome
+ source = https://raw.githubusercontent.com/colinkeenan/tchrome/v1.3/tchrome.conf
+ source = https://raw.githubusercontent.com/colinkeenan/tchrome/v1.3/tchrome.desktop
+ source = https://raw.githubusercontent.com/colinkeenan/tchrome/v1.3/tchrome.svg
md5sums = 45abeb3edac87aaa0980b48f01172937
md5sums = 3bab05dbc5357bbe934942503a79c6a3
- md5sums = 7a6ae702e159c102ed888007e0f25358
+ md5sums = bcd4d82fa14628eb47ffc6e8cb66c0cf
+ md5sums = 5f1dfb475e6f52d7169795fa146de4e0
pkgname = tchrome
diff --git a/PKGBUILD b/PKGBUILD
index 9bac8440af81..23713271b09d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Colin Keenan <colinnkeenan at gmail dot com>
pkgname=tchrome
-pkgver=1.2
+pkgver=1.3
pkgrel=1
pkgdesc="Close Chrome browser including background, or launch a version of Google Chrome/Chromium"
arch=('any')
@@ -11,13 +11,16 @@ install=${pkgname}.install
source=(https://raw.githubusercontent.com/colinkeenan/${pkgname}/v${pkgver}/${pkgname}
https://raw.githubusercontent.com/colinkeenan/${pkgname}/v${pkgver}/${pkgname}.conf
- https://raw.githubusercontent.com/colinkeenan/${pkgname}/v${pkgver}/${pkgname}.desktop)
+ https://raw.githubusercontent.com/colinkeenan/${pkgname}/v${pkgver}/${pkgname}.desktop
+ https://raw.githubusercontent.com/colinkeenan/${pkgname}/v${pkgver}/${pkgname}.svg)
md5sums=('45abeb3edac87aaa0980b48f01172937'
'3bab05dbc5357bbe934942503a79c6a3'
- '7a6ae702e159c102ed888007e0f25358')
+ 'bcd4d82fa14628eb47ffc6e8cb66c0cf'
+ '5f1dfb475e6f52d7169795fa146de4e0')
package() {
install -D -m644 ${pkgname}.conf "$pkgdir/etc/${pkgname}.conf"
install -D -m644 ${pkgname}.desktop "$pkgdir/usr/share/applications/${pkgname}.desktop"
+ install -D -m644 ${pkgname}.svg "$pkgdir/usr/share/icons/hicolor/scalable/apps/${pkgname}.svg"
install -D -m755 ${pkgname} "$pkgdir/usr/bin/${pkgname}"
}
diff --git a/tchrome.install b/tchrome.install
index f19d53817061..13b5702aef49 100644
--- a/tchrome.install
+++ b/tchrome.install
@@ -13,7 +13,9 @@ BLUE="${BOLD}$(tput setaf 4)"
YELLOW="${BOLD}$(tput setaf 3)"
post_install() {
- note "The script is named 'tchrome' and the desktop calls it 'Toggle Chrome (tchrome)'. This is meant to live on a panel in a launcher. Click to close all Chrome windows and background processes, or launch the version of the Chrome Browser specified in /etc/tchrome.conf if not already running. If running the scrip from the command line, make sure it runs from bash."
+ note "The script is named 'tchrome' and the desktop calls it 'Toggle Chrome (tchrome)'. This is meant to live on a panel in a launcher. Click to close all Chrome windows and background processes, or launch the version of the Chrome Browser specified in /etc/tchrome.conf if not already running. If running the scrip from the command line, make sure it runs from bash.
+
+ On update, you will have to re-edit /etc/tchrome.conf, remove tchrome from the panel launcher, and then add it back to the panel launcher."
}