summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2017-02-21 15:05:28 -0500
committerTony Lambiris2017-02-21 15:05:28 -0500
commit9bea0924b44c6232c0646c3692e71cbd70f68cf6 (patch)
treee03648da903875df55cbccb275fe6a1990dcff40
parent721d491e2d3bca78e59d1c58b7a76e68ff8193ff (diff)
downloadaur-9bea0924b44c6232c0646c3692e71cbd70f68cf6.tar.gz
Version update for tcl-nothreading
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD15
-rw-r--r--tcl-fix-segv.patch26
3 files changed, 11 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cf5b07652340..1262d0a7905f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,17 @@
pkgbase = tcl-nothreading
pkgdesc = The Tcl scripting language with threading disabled
- pkgver = 8.6.5
- pkgrel = 2
+ pkgver = 8.6.6
+ pkgrel = 1
url = http://tcl.sourceforge.net/
arch = i686
arch = x86_64
license = custom
depends = zlib
- provides = tcl=8.6.5
+ provides = tcl=8.6.6
conflicts = tcl
options = staticlibs
- source = http://downloads.sourceforge.net/sourceforge/tcl/tcl8.6.5-src.tar.gz
- source = tcl-fix-segv.patch
- sha1sums = c3a50ea58dac00a3c7e83cb4a4651c40d0f55160
- sha1sums = 1ec4fd9d159b920c15655936b1418034387114f0
+ source = http://downloads.sourceforge.net/sourceforge/tcl/tcl8.6.6-src.tar.gz
+ sha1sums = 169dd1589cad62c9fac4257c113db245da502cd0
pkgname = tcl-nothreading
diff --git a/PKGBUILD b/PKGBUILD
index 436d7a64fe89..017a6327e32b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,23 @@
# Maintainer: Tony Lambiris <tony@criticalstack.com>
pkgname=tcl-nothreading
-pkgver=8.6.5
-pkgrel=2
+pkgver=8.6.6
+pkgrel=1
pkgdesc="The Tcl scripting language with threading disabled"
arch=('i686' 'x86_64')
url="http://tcl.sourceforge.net/"
license=('custom')
depends=('zlib')
-provides=('tcl=8.6.5')
+provides=('tcl=8.6.6')
conflicts=('tcl')
options=('staticlibs')
-source=(http://downloads.sourceforge.net/sourceforge/tcl/tcl${pkgver}-src.tar.gz tcl-fix-segv.patch)
-sha1sums=('c3a50ea58dac00a3c7e83cb4a4651c40d0f55160'
- '1ec4fd9d159b920c15655936b1418034387114f0')
+source=(http://downloads.sourceforge.net/sourceforge/tcl/tcl${pkgver}-src.tar.gz)
+sha1sums=('169dd1589cad62c9fac4257c113db245da502cd0')
prepare() {
cd tcl${pkgver}
# we build the tcl sqlite interface in sqlite-tcl package
rm -rf pkgs/sqlite3*
- # fix SEGV if cpu supports HLE/RTM http://core.tcl.tk/tcl/info/d3071887dbc7aeac
- patch -p1 -i ../tcl-fix-segv.patch
}
build() {
@@ -49,7 +46,7 @@ package() {
-e "s#${srcdir}/tcl${pkgver}/pkgs/$tdbcver#/usr/include#" \
-i "${pkgdir}/usr/lib/$tdbcver/tdbcConfig.sh"
- itclver=itcl4.0.4
+ itclver=itcl4.0.5
sed -e "s#${srcdir}/tcl${pkgver}/unix/pkgs/$itclver#/usr/lib/$itclver#" \
-e "s#${srcdir}/tcl${pkgver}/pkgs/$itclver/generic#/usr/include#" \
-e "s#${srcdir}/tcl${pkgver}/pkgs/$itclver#/usr/include#" \
diff --git a/tcl-fix-segv.patch b/tcl-fix-segv.patch
deleted file mode 100644
index 1eaa11d2244f..000000000000
--- a/tcl-fix-segv.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 55234833327f1ee7469552fa103c316e5405f8b0 Mon Sep 17 00:00:00 2001
-From: "nijtmans@users.sourceforge.net" <jan.nijtmans>
-Date: Mon, 21 Mar 2016 09:05:34 +0000
-Subject: [PATCH] Proposed fix for [d3071887dbc7aeac]: Fix SEGV in
- Tcl_FinalizeNotifier()
-
----
- unix/tclUnixNotfy.c | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/unix/tclUnixNotfy.c b/unix/tclUnixNotfy.c
-index 48ba0cc..3946c7d 100644
---- a/unix/tclUnixNotfy.c
-+++ b/unix/tclUnixNotfy.c
-@@ -433,9 +433,11 @@ Tcl_FinalizeNotifier(
- "unable to write q to triggerPipe");
- }
- close(triggerPipe);
-+ pthread_mutex_lock(&notifierMutex);
- while(triggerPipe != -1) {
- pthread_cond_wait(&notifierCV, &notifierMutex);
- }
-+ pthread_mutex_unlock(&notifierMutex);
- if (notifierThreadRunning) {
- int result = pthread_join((pthread_t) notifierThread, NULL);
-