summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMircea Dan2020-01-14 21:47:59 -0800
committerMircea Dan2020-01-14 21:47:59 -0800
commit92ebc88e29070f97e04a15021d16cfdf12825036 (patch)
tree6dab38b05a95b83a0209ed5e51a0921c0044635f
downloadaur-92ebc88e29070f97e04a15021d16cfdf12825036.tar.gz
original submit for TclSOAP package
-rw-r--r--.SRCINFO16
-rwxr-xr-xPKGBUILD36
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..daa1fc13c8b5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = tclsoap
+ pkgdesc = The package provides a mechanism to bind Tcl command procedures to remote procedure calls using the Simple Object Access Protocol (SOAP) and XML-RPC over HTTP. Both client and server code is provided.
+ pkgver = 1.6.7.1
+ pkgrel = 1
+ url = http://tclsoap.sourceforge.net
+ arch = any
+ license = MIT
+ depends = tcl
+ depends = tclxml
+ optdepends = tdom: technically not needed, but you want it if you want this package
+ optdepends = tcllib: technically not needed, but you want it if you want this package
+ source = https://github.com/ByReaL/tclsoap/archive/1.6.7.1.tar.gz
+ md5sums = 9f0fbf71b095728ab932a39bf367b445
+
+pkgname = tclsoap
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..68074ab1e505
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Mircea Dan Gheorghe <mirceadan@gmail.com>
+# Contributor: Mircea Dan Gheorghe <mirceadan@gmail.com>
+
+
+# inspired from
+#https://wiki.archlinux.org/index.php/creating_packages
+#https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=tclxml
+#https://bbs.archlinux.org/viewtopic.php?id=243517
+
+pkgname=tclsoap
+pkgver=1.6.7.1
+pkgrel=1
+pkgdesc="The package provides a mechanism to bind Tcl command procedures to remote procedure calls using the Simple Object Access Protocol (SOAP) and XML-RPC over HTTP. Both client and server code is provided."
+url="http://tclsoap.sourceforge.net"
+arch=('any')
+license=('MIT')
+depends=('tcl' 'tclxml')
+optdepends=(
+ 'tdom: technically not needed, but you want it if you want this package'
+ 'tcllib: technically not needed, but you want it if you want this package'
+)
+source=("https://github.com/ByReaL/tclsoap/archive/$pkgver.tar.gz")
+md5sums=('9f0fbf71b095728ab932a39bf367b445')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ bash ./configure --prefix=/usr
+ make
+}
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make DESTDIR=$pkgdir install
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+ install -d $pkgdir/usr/share/doc/$pkgname
+ cp -r doc/* $pkgdir/usr/share/doc/$pkgname
+}