summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgéballin2021-11-18 11:21:04 +0100
committergéballin2021-11-18 11:21:04 +0100
commitf49bb44229d30994b5755dee0ba7d99552feb509 (patch)
tree8b704a767ec8a1f59583c8a7dfc81fdeb744bd36
parentcf71d3a6343ddc932faa095e6f40aaf9cd44a7eb (diff)
downloadaur-f49bb44229d30994b5755dee0ba7d99552feb509.tar.gz
Upgrade to 3.3.1 so it can compile on modern gcc.
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD17
2 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d5e8e2000452..fb4f5b4a0f84 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = tclxml
pkgdesc = XML support for the Tcl scripting language
- pkgver = 3.2
- pkgrel = 2
- url = http://tclxml.sourceforge.net
+ pkgver = 3.3.1
+ pkgrel = 1
+ url = https://github.com/flightaware/TclXML
arch = i686
arch = x86_64
license = custom:BSD
@@ -10,8 +10,7 @@ pkgbase = tclxml
depends = bash
optdepends = tcl: technically not needed, but you want it if you want this package
optdepends = tcllib: technically not needed, but you want it if you want this package
- source = http://downloads.sourceforge.net/sourceforge/tclxml/tclxml-3.2.tar.gz
- md5sums = 9d1605246c899eff7db591bca3c23200
+ source = https://github.com/flightaware/TclXML/archive/refs/tags/v3.3.1.tar.gz
+ md5sums = fb8106c41efcb5053389007851d2a237
pkgname = tclxml
-
diff --git a/PKGBUILD b/PKGBUILD
index cbfa22434db4..0d228fb0730d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,27 @@
# Contributor: Pavel Borzenkov <pavel.borzenkov@gmail.com>
-# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
+# Maintainer: Geballin - Guillaume Ballin <macniaque at free dot fr>
pkgname=tclxml
-pkgver=3.2
-pkgrel=2
+pkgver=3.3.1
+pkgrel=1
pkgdesc="XML support for the Tcl scripting language"
-url="http://tclxml.sourceforge.net"
+url="https://github.com/flightaware/TclXML"
arch=('i686' 'x86_64')
license=('custom:BSD')
depends=('libxslt' 'bash')
optdepends=('tcl: technically not needed, but you want it if you want this package'
'tcllib: technically not needed, but you want it if you want this package')
-source=("http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz")
-md5sums=('9d1605246c899eff7db591bca3c23200')
+source=("https://github.com/flightaware/TclXML/archive/refs/tags/v$pkgver.tar.gz")
+md5sums=('fb8106c41efcb5053389007851d2a237')
build() {
- cd $srcdir/$pkgname-$pkgver
+ cd $srcdir/TclXML-$pkgver
./configure --prefix=/usr
make
}
package() {
- cd $srcdir/$pkgname-$pkgver
+ cd $srcdir/TclXML-$pkgver
make DESTDIR=$pkgdir install
install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
install -d $pkgdir/usr/share/doc/$pkgname