summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Quirk2015-06-13 09:04:05 +0200
committerRichard Quirk2015-06-13 09:04:05 +0200
commitca7773b79318aee2b7a64c1504b3a46fce3abd39 (patch)
tree3e861739122cf001cb14a46b1848bc882ce0cd44
downloadaur-ca7773b79318aee2b7a64c1504b3a46fce3abd39.tar.gz
import from aur
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD30
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e5e6c6fe04cf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by makepkg 4.2.1
+# Sat Jun 13 07:03:55 UTC 2015
+pkgbase = tcpstat
+ pkgdesc = network interface statistics, with output similar to vmstat(8)
+ pkgver = 1.5
+ pkgrel = 3
+ url = http://www.frenchfries.net/paul/tcpstat/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = coreutils
+ makedepends = gawk
+ makedepends = make
+ makedepends = gcc
+ makedepends = binutils
+ makedepends = glibc
+ makedepends = libpcap
+ depends = glibc
+ depends = libpcap
+ source = http://www.frenchfries.net/paul/tcpstat/tcpstat-1.5.tar.gz
+ md5sums = 93ca0ffb8f319ecf2e42ff925a7e6854
+
+pkgname = tcpstat
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c7a4f1ff0a2d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Contributor: Mark Smith <markzzzsmith@yahoo.com.au>
+pkgname=tcpstat
+pkgver=1.5
+pkgrel=3
+pkgdesc="network interface statistics, with output similar to vmstat(8)"
+arch=('i686' 'x86_64')
+url="http://www.frenchfries.net/paul/tcpstat/"
+license=('BSD')
+depends=('glibc' 'libpcap')
+makedepends=('coreutils' 'gawk' 'make' 'gcc' 'binutils' 'glibc' 'libpcap')
+source=($url$pkgname-$pkgver.tar.gz)
+md5sums=('93ca0ffb8f319ecf2e42ff925a7e6854')
+
+build() {
+
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+ # tcpprof not built, so don't install manual page
+ rm $pkgdir/usr/man/man1/tcpprof.1
+
+ install -D -m444 LICENSE \
+ $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}