summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKspLite2021-01-06 17:07:06 +0800
committerKspLite2021-01-06 17:07:06 +0800
commit1f739878e370959940c742c9d044be695631bec4 (patch)
treefc34ebaf594a13a4e6c9adb9aaeacbfa331a3272
downloadaur-1f739878e370959940c742c9d044be695631bec4.tar.gz
Init
-rw-r--r--.SRCINFO97
-rw-r--r--PKGBUILD146
2 files changed, 243 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1513ac059644
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,97 @@
+pkgbase = tdesktop-x64
+ pkgdesc = Third party Telegram Desktop client with various enhancements (dev branch)
+ pkgver = 2.5.1.1.r3.gceda77176
+ pkgrel = 1
+ url = https://github.com/TDesktop-x64/tdesktop
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ makedepends = git
+ makedepends = ninja
+ makedepends = python
+ makedepends = range-v3
+ makedepends = tl-expected
+ makedepends = microsoft-gsl
+ makedepends = libtg_owt
+ depends = hunspell
+ depends = ffmpeg
+ depends = hicolor-icon-theme
+ depends = lz4
+ depends = minizip
+ depends = openal
+ depends = qt5-imageformats
+ depends = xxhash
+ depends = libdbusmenu-qt5
+ depends = qt5-wayland
+ depends = gtk3
+ optdepends = ttf-opensans: default Open Sans font family
+ provides = tdesktop-x64
+ conflicts = telegram-desktop
+ conflicts = tdesktop-x64
+ source = tdesktop::git+https://github.com/TDesktop-x64/tdesktop.git#tag=dev
+ source = libtgvoip::git+https://github.com/telegramdesktop/libtgvoip
+ source = GSL::git+https://github.com/Microsoft/GSL.git
+ source = Catch::git+https://github.com/philsquared/Catch
+ source = xxHash::git+https://github.com/Cyan4973/xxHash.git
+ source = rlottie::git+https://github.com/desktop-app/rlottie.git
+ source = lz4::git+https://github.com/lz4/lz4.git
+ source = lib_crl::git+https://github.com/desktop-app/lib_crl.git
+ source = lib_rpl::git+https://github.com/desktop-app/lib_rpl.git
+ source = lib_base::git+https://github.com/desktop-app/lib_base.git
+ source = codegen::git+https://github.com/desktop-app/codegen.git
+ source = lib_ui::git+https://github.com/desktop-app/lib_ui.git
+ source = lib_rlottie::git+https://github.com/desktop-app/lib_rlottie.git
+ source = lib_lottie::git+https://github.com/desktop-app/lib_lottie.git
+ source = lib_tl::git+https://github.com/desktop-app/lib_tl.git
+ source = lib_spellcheck::git+https://github.com/desktop-app/lib_spellcheck
+ source = lib_storage::git+https://github.com/desktop-app/lib_storage.git
+ source = cmake_helpers::git+https://github.com/TDesktop-x64/cmake_helpers.git
+ source = expected::git+https://github.com/TartanLlama/expected
+ source = QR-Code-generator::git+https://github.com/nayuki/QR-Code-generator
+ source = lib_qr::git+https://github.com/desktop-app/lib_qr.git
+ source = libdbusmenu-qt::git+https://github.com/desktop-app/libdbusmenu-qt.git
+ source = hunspell::git+https://github.com/hunspell/hunspell
+ source = materialdecoration::git+https://github.com/desktop-app/materialdecoration.git
+ source = range-v3::git+https://github.com/ericniebler/range-v3.git
+ source = fcitx-qt5::git+https://github.com/fcitx/fcitx-qt5.git
+ source = nimf::git+https://github.com/hamonikr/nimf.git
+ source = hime::git+https://github.com/hime-ime/hime.git
+ source = qt5ct::git+https://github.com/desktop-app/qt5ct.git
+ source = fcitx5-qt::git+https://github.com/fcitx/fcitx5-qt.git
+ source = lib_webrtc::git+https://github.com/desktop-app/lib_webrtc.git
+ source = tgcalls::git+https://github.com/TelegramMessenger/tgcalls.git
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+
+pkgname = tdesktop-x64
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2869339ada8c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,146 @@
+# Maintainer: KspLite <ksplite@outlook.com>
+# Contributor: Jiachen YANG <farseerfc@gmail.com>
+pkgname=tdesktop-x64
+pkgver=2.5.1.1.r3.gceda77176
+pkgrel=1
+pkgdesc='Third party Telegram Desktop client with various enhancements (dev branch)'
+arch=('x86_64')
+url="https://github.com/TDesktop-x64/tdesktop"
+license=('GPL3')
+depends=('hunspell' 'ffmpeg' 'hicolor-icon-theme' 'lz4' 'minizip' 'openal'
+ 'qt5-imageformats' 'xxhash' 'libdbusmenu-qt5' 'qt5-wayland' 'gtk3')
+makedepends=('cmake' 'git' 'ninja' 'python' 'range-v3' 'tl-expected' 'microsoft-gsl' 'libtg_owt')
+optdepends=('ttf-opensans: default Open Sans font family')
+provides=("tdesktop-x64")
+conflicts=("telegram-desktop" "tdesktop-x64")
+source=("tdesktop::git+https://github.com/TDesktop-x64/tdesktop.git#tag=dev"
+ "libtgvoip::git+https://github.com/telegramdesktop/libtgvoip"
+ "GSL::git+https://github.com/Microsoft/GSL.git"
+ "Catch::git+https://github.com/philsquared/Catch"
+ "xxHash::git+https://github.com/Cyan4973/xxHash.git"
+ "rlottie::git+https://github.com/desktop-app/rlottie.git"
+ "lz4::git+https://github.com/lz4/lz4.git"
+ "lib_crl::git+https://github.com/desktop-app/lib_crl.git"
+ "lib_rpl::git+https://github.com/desktop-app/lib_rpl.git"
+ "lib_base::git+https://github.com/desktop-app/lib_base.git"
+ "codegen::git+https://github.com/desktop-app/codegen.git"
+ "lib_ui::git+https://github.com/desktop-app/lib_ui.git"
+ "lib_rlottie::git+https://github.com/desktop-app/lib_rlottie.git"
+ "lib_lottie::git+https://github.com/desktop-app/lib_lottie.git"
+ "lib_tl::git+https://github.com/desktop-app/lib_tl.git"
+ "lib_spellcheck::git+https://github.com/desktop-app/lib_spellcheck"
+ "lib_storage::git+https://github.com/desktop-app/lib_storage.git"
+ "cmake_helpers::git+https://github.com/TDesktop-x64/cmake_helpers.git"
+ "expected::git+https://github.com/TartanLlama/expected"
+ "QR-Code-generator::git+https://github.com/nayuki/QR-Code-generator"
+ "lib_qr::git+https://github.com/desktop-app/lib_qr.git"
+ "libdbusmenu-qt::git+https://github.com/desktop-app/libdbusmenu-qt.git"
+ "hunspell::git+https://github.com/hunspell/hunspell"
+ "materialdecoration::git+https://github.com/desktop-app/materialdecoration.git"
+ "range-v3::git+https://github.com/ericniebler/range-v3.git"
+ "fcitx-qt5::git+https://github.com/fcitx/fcitx-qt5.git"
+ "nimf::git+https://github.com/hamonikr/nimf.git"
+ "hime::git+https://github.com/hime-ime/hime.git"
+ "qt5ct::git+https://github.com/desktop-app/qt5ct.git"
+ "fcitx5-qt::git+https://github.com/fcitx/fcitx5-qt.git"
+ "lib_webrtc::git+https://github.com/desktop-app/lib_webrtc.git"
+ "tgcalls::git+https://github.com/TelegramMessenger/tgcalls.git"
+)
+sha512sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
+pkgver() {
+ cd "$srcdir/tdesktop"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$srcdir/tdesktop"
+ git submodule init
+ git config submodule.Telegram/ThirdParty/libtgvoip.url "$srcdir/libtgvoip"
+ git config submodule.Telegram/ThirdParty/GSL.url "$srcdir/GSL"
+ git config submodule.Telegram/ThirdParty/Catch.url "$srcdir/Catch"
+ git config submodule.Telegram/ThirdParty/xxHash.url "$srcdir/xxHash"
+ git config submodule.Telegram/ThirdParty/rlottie.url "$srcdir/rlottie"
+ git config submodule.Telegram/ThirdParty/lz4.url "$srcdir/lz4"
+ git config submodule.Telegram/lib_crl.url "$srcdir/lib_crl"
+ git config submodule.Telegram/lib_rpl.url "$srcdir/lib_rpl"
+ git config submodule.Telegram/lib_base.url "$srcdir/lib_base"
+ git config submodule.Telegram/codegen.url "$srcdir/codegen"
+ git config submodule.Telegram/lib_ui.url "$srcdir/lib_ui"
+ git config submodule.Telegram/lib_rlottie.url "$srcdir/lib_rlottie"
+ git config submodule.Telegram/lib_lottie.url "$srcdir/lib_lottie"
+ git config submodule.Telegram/lib_tl.url "$srcdir/lib_tl"
+ git config submodule.Telegram/lib_spellcheck.url "$srcdir/lib_spellcheck"
+ git config submodule.Telegram/lib_storage.url "$srcdir/lib_storage"
+ git config submodule.cmake.url "$srcdir/cmake_helpers"
+ git config submodule.Telegram/ThirdParty/expected.url "$srcdir/expected"
+ git config submodule.Telegram/ThirdParty/QR.url "$srcdir/QR-Code-generator"
+ git config submodule.Telegram/lib_qr.url "$srcdir/lib_qr"
+ git config submodule.Telegram/ThirdParty/libdbusmenu-qt.url "$srcdir/libdbusmenu-qt"
+ git config sumbodule.Telegram/ThirdParty/hunspell.url "$srcdir/hunspell"
+ git config sumbodule.Telegram/ThirdParty/materialdecoration.url "$srcdir/materialdecoration"
+ git config sumbodule.Telegram/ThirdParty/range-v3.url "$srcdir/range-v3"
+ git config sumbodule.Telegram/ThirdParty/fcitx-qt5.url "$srcdir/fcitx-qt5"
+ git config sumbodule.Telegram/ThirdParty/nimf.url "$srcdir/nimf"
+ git config sumbodule.Telegram/ThirdParty/hime.url "$srcdir/hime"
+ git config sumbodule.Telegram/ThirdParty/qt5ct.url "$srcdir/qt5ct"
+ git config sumbodule.Telegram/ThirdParty/fcitx5-qt.url "$srcdir/fcitx5-qt"
+ git config sumbodule.Telegram/lib_webrtc.url "$srcdir/lib_webrtc"
+ git config sumbodule.Telegram/ThirdParty/tgcalls.url "$srcdir/tgcalls"
+ git submodule update
+
+ cd cmake
+ # force webrtc link to libjpeg
+ echo "target_link_libraries(external_webrtc INTERFACE jpeg)" | tee -a external/webrtc/CMakeLists.txt
+}
+
+build() {
+ cd "$srcdir/tdesktop"
+
+ # Upstream is using the same API ID&Hash as the official one
+ cmake . \
+ -B build \
+ -G Ninja \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DTDESKTOP_API_ID=611335 \
+ -DTDESKTOP_API_HASH=d524b414d21f4d37f08684c1df41ac9c \
+ -DTDESKTOP_LAUNCHER_BASENAME="telegramdesktop" \
+ -DDESKTOP_APP_SPECIAL_TARGET=""
+ ninja -C build
+}
+
+package() {
+ cd "$srcdir/tdesktop"
+ DESTDIR=$pkgdir ninja -C build install
+}