summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F Rødseth2015-06-10 15:04:02 +0200
committerAlexander F Rødseth2015-06-10 15:04:02 +0200
commitf2b51913743b8fabcbf03c4a20d12990f525d17d (patch)
tree015247b98e5ada5f31a790c496d728df5646c8e3
downloadaur-f2b51913743b8fabcbf03c4a20d12990f525d17d.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD35
-rw-r--r--readline63.patch32
3 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..009c55b220ac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = tdl
+ pkgdesc = TODO list manager
+ pkgver = 1.5.2
+ pkgrel = 7
+ url = https://github.com/rc0/tdl
+ arch = x86_64
+ arch = i686
+ license = GPL
+ makedepends = git
+ depends = readline
+ source = tdl::git://github.com/T-J-Teru/tdl.git#commit=382c52a2d1f2d064110c189459fe09a6edb12761
+ source = readline63.patch
+ md5sums = SKIP
+ md5sums = dada1488632f9d672e75e15cfb011ecb
+
+pkgname = tdl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4c2b25336f72
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer:
+# Contributor: Alexander Rødseth <rodseth@gmail.com>
+# Contributor: Jeff Mickey <j@codemac.net>
+
+pkgname=tdl
+pkgver=1.5.2
+pkgrel=7
+pkgdesc='TODO list manager'
+arch=('x86_64' 'i686')
+url='https://github.com/rc0/tdl'
+license=('GPL')
+depends=('readline')
+makedepends=('git')
+source=("$pkgname::git://github.com/T-J-Teru/tdl.git#commit=382c52a2d1f2d064110c189459fe09a6edb12761" 'readline63.patch')
+md5sums=('SKIP'
+ 'dada1488632f9d672e75e15cfb011ecb')
+
+prepare() {
+ cd "$pkgname"
+
+ patch -p1 -i "$srcdir/readline63.patch"
+}
+
+build() {
+ cd "$pkgname"
+
+ ./configure --prefix=/usr --mandir=/usr/share/man
+ make
+}
+
+package() {
+ make -C "$pkgname" DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/readline63.patch b/readline63.patch
new file mode 100644
index 000000000000..b42ddec02066
--- /dev/null
+++ b/readline63.patch
@@ -0,0 +1,32 @@
+--- a/inter.c 2014-04-12 18:48:39.020103780 +0200
++++ b/inter.c 2014-04-12 18:48:33.323365100 +0200
+@@ -556,7 +556,7 @@
+ static char *interactive_text_readline(char *prompt, char *initval, int *is_blank, int *error)/*{{{*/
+ {
+ char *line;
+- Function *old_rl_pre_input_hook = NULL;
++ rl_command_func_t *old_rl_pre_input_hook = NULL;
+
+ *error = 0;
+ old_rl_pre_input_hook = rl_pre_input_hook;
+@@ -633,9 +633,9 @@
+ #ifdef USE_READLINE
+ if (isatty(0)) {
+ char *result;
+- rl_attempted_completion_function = (CPPFunction *) null_tdl_completion;
++ rl_attempted_completion_function = null_tdl_completion;
+ result = interactive_text_readline(prompt, initval, is_blank, error);
+- rl_attempted_completion_function = (CPPFunction *) tdl_completion;
++ rl_attempted_completion_function = tdl_completion;
+ return result;
+ } else {
+ /* In case someone wants to drive tdl from a script, by redirecting stdin to it. */
+@@ -653,7 +653,7 @@
+ #ifdef USE_READLINE
+ if (isatty(0)) {
+ rl_completion_entry_function = NULL;
+- rl_attempted_completion_function = (CPPFunction *) tdl_completion;
++ rl_attempted_completion_function = tdl_completion;
+ interactive_readline();
+ } else {
+ /* In case someone wants to drive tdl from a script, by redirecting stdin to it. */