summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2022-07-07 13:18:17 +0200
committerFabioLolix2022-07-07 13:18:17 +0200
commit0835e08e9897e4310eab03cd043084c70eb57443 (patch)
tree4e4208a01cd67961e7644288af96c139e5381d40
parent2dfccbf6a5e5359a3d27228669db84e649deceba (diff)
downloadaur-0835e08e9897e4310eab03cd043084c70eb57443.tar.gz
v61.0.0
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD19
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96a2c3d0e259..db25c311c1ca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = tea-qt
pkgdesc = Powerful text editor for Linux, *BSD, Windows, OS/2, Mac and Haiku OS with PDF and DJVU support
- pkgver = 60.7.0
+ pkgver = 61.0.0
pkgrel = 1
url = https://tea.ourproject.org/
arch = x86_64
license = GPL3
makedepends = cmake
+ makedepends = git
depends = qt6-base
depends = qt6-5compat
depends = hunspell
optdepends = poppler-qt6: open and search text in PDF files
optdepends = djvulibre: open and search in DJVU
- source = tea-qt-60.7.0.tar.gz::https://github.com/psemiletov/tea-qt/archive/refs/tags/60.7.0.tar.gz
- sha512sums = 980068d3cb080128711142c3e4e437a4560547e78ee315d0e6967566db7c3af2c9f6330c403bcd49395ae12f01c3f5b9b17e8ab095a12c9f616baf0441b0fc93
+ source = git+https://github.com/psemiletov/tea-qt.git#tag=61.0.0
+ sha512sums = SKIP
pkgname = tea-qt
diff --git a/PKGBUILD b/PKGBUILD
index 5cd2cdc391ae..c2e0e116b78b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,25 +7,25 @@
# Contributor: Holger Rauch < holger dot rauch at posteo dot de >
pkgname=tea-qt
-pkgver=60.7.0
+pkgver=61.0.0
pkgrel=1
pkgdesc="Powerful text editor for Linux, *BSD, Windows, OS/2, Mac and Haiku OS with PDF and DJVU support"
arch=(x86_64)
url="https://tea.ourproject.org/"
license=(GPL3)
depends=(qt6-base qt6-5compat hunspell)
-makedepends=(cmake)
+makedepends=(cmake git)
optdepends=('poppler-qt6: open and search text in PDF files'
'djvulibre: open and search in DJVU')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/psemiletov/tea-qt/archive/refs/tags/${pkgver}.tar.gz")
-sha512sums=('980068d3cb080128711142c3e4e437a4560547e78ee315d0e6967566db7c3af2c9f6330c403bcd49395ae12f01c3f5b9b17e8ab095a12c9f616baf0441b0fc93')
+source=("git+https://github.com/psemiletov/tea-qt.git#tag=${pkgver}")
+sha512sums=('SKIP')
prepare() {
- mkdir -p "${srcdir}/tea-qt-${pkgver}/build"
+ mkdir -p "${srcdir}/tea-qt/build"
}
build() {
- cd "${srcdir}/tea-qt-${pkgver}/build"
+ cd "${srcdir}/tea-qt/build"
cmake .. \
-DCMAKE_INSTALL_PREFIX=/usr \
-DUSE_PDF=ON \
@@ -33,13 +33,12 @@ build() {
make
- cd "${srcdir}/tea-qt-${pkgver}/desktop"
+ cd "${srcdir}/tea-qt/desktop"
sed -i 's/tea %U/tea-qt %U/g' tea.desktop
}
package(){
- cd "${srcdir}/tea-qt-${pkgver}/build"
+ cd "${srcdir}/tea-qt/build"
make DESTDIR="${pkgdir}" install
mv "${pkgdir}/usr/bin/tea" "${pkgdir}/usr/bin/tea-qt"
-}
-
+} \ No newline at end of file