summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPetr Semiletov2021-07-19 22:47:52 +0300
committerPetr Semiletov2021-07-19 22:47:52 +0300
commit6d816d6105feba370204b77da917c487dac947bb (patch)
treed5c3c51f782ca0389d4facd7dc5b13cfda44c2f1
parent1c300c82ed7a827c588473f109c816610e62b81a (diff)
downloadaur-6d816d6105feba370204b77da917c487dac947bb.tar.gz
60.4.0.r1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 895a678e9fe6..157328b73e5f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tea-qt-git
- pkgdesc = Powerful text editor for Linux, *BSD, Windows, OS/2, Mac and Haiku OS
- pkgver = 60.4.0.r2
+ pkgdesc = Rich-featured text editor for Linux, *BSD, Windows, OS/2, Mac and Haiku OS. Build from stable git-commit with PDF and DJVU support.
+ pkgver = 60.4.0.r3
pkgrel = 1
url = http://tea.ourproject.org
arch = x86_64
@@ -13,6 +13,8 @@ pkgbase = tea-qt-git
depends = zlib
depends = hunspell
depends = desktop-file-utils
+ optdepends = poppler-qt6: open and search text in PDF files
+ optdepends = djvulibre: open and search in DJVU
provides = tea
conflicts = tea
source = git+https://github.com/psemiletov/tea-qt.git
diff --git a/PKGBUILD b/PKGBUILD
index 1b54d1b8372d..df02657de8df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,16 @@
# Maintainer: Peter Semiletov <peter.semiletov@gmail.com>
pkgname=tea-qt-git
-pkgver=60.4.0.r2
+pkgver=60.4.0.r3
pkgrel=1
-pkgdesc="Powerful text editor for Linux, *BSD, Windows, OS/2, Mac and Haiku OS"
+pkgdesc="Rich-featured text editor for Linux, *BSD, Windows, OS/2, Mac and Haiku OS. Build from stable git-commit with PDF and DJVU support."
arch=('x86_64')
url="http://tea.ourproject.org"
license=('GPL')
depends=('qt6-base' 'qt6-5compat' 'gcc-libs' 'zlib' 'hunspell' 'desktop-file-utils')
+
+optdepends=('poppler-qt6: open and search text in PDF files' 'djvulibre: open and search in DJVU')
+
makedepends=('cmake' 'git')
provides=('tea')
conflicts=('tea')
@@ -18,7 +21,7 @@ md5sums=('SKIP')
build() {
mkdir -p "${srcdir}/tea-qt/b"
cd "${srcdir}/tea-qt/b"
- cmake .. -DCMAKE_INSTALL_PREFIX=/usr
+ cmake .. -DUSE_PDF=ON -DUSE_DJVU=ON -DCMAKE_INSTALL_PREFIX=/usr
make
}