summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPetr Semiletov2021-07-19 19:23:25 +0300
committerPetr Semiletov2021-07-19 19:23:25 +0300
commit7e8d9518502b1e70d48c1b4ca1c74dde83fafc9b (patch)
tree5faec92299da58cd533add7d706d8bb49ff8c8b5
downloadaur-7e8d9518502b1e70d48c1b4ca1c74dde83fafc9b.tar.gz
60.4.0.r1
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD28
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d0d3c7198033
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = tea-qt-git
+ pkgdesc = Powerful text editor for Linux, *BSD, Windows, OS/2, Mac and Haiku OS
+ pkgver = 60.4.0.r1
+ pkgrel = 1
+ url = http://tea.ourproject.org
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = git
+ depends = qt6-base
+ depends = qt6-5compat
+ depends = gcc-libs
+ depends = zlib
+ depends = hunspell
+ depends = desktop-file-utils
+ provides = tea
+ conflicts = tea
+ source = git+https://github.com/psemiletov/tea-qt.git
+ md5sums = SKIP
+
+pkgname = tea-qt-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f32f10758ab9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Peter Semiletov <peter.semiletov@gmail.com>
+
+pkgname=tea-qt-git
+pkgver=60.4.0.r1
+pkgrel=1
+pkgdesc="Powerful text editor for Linux, *BSD, Windows, OS/2, Mac and Haiku OS"
+arch=('x86_64')
+url="http://tea.ourproject.org"
+license=('GPL')
+depends=('qt6-base' 'qt6-5compat' 'gcc-libs' 'zlib' 'hunspell' 'desktop-file-utils')
+makedepends=('cmake' 'git')
+provides=('tea')
+conflicts=('tea')
+
+source=("git+https://github.com/psemiletov/tea-qt.git")
+md5sums=('SKIP')
+
+build() {
+ mkdir -p "${srcdir}/tea-qt/b"
+ cd "${srcdir}/tea-qt/b"
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package(){
+ cd "${srcdir}/tea-qt/b"
+ make DESTDIR="$pkgdir" install
+}