summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2018-10-14 05:20:39 -0700
committerAlexander F. Rødseth2018-10-14 05:20:39 -0700
commit95b360a267d3501c4b0a5a7091e1b132ddf06d14 (patch)
treef34bbc01a7f28bb34d42668c1489695e372fa20d
downloadaur-95b360a267d3501c4b0a5a7091e1b132ddf06d14.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b3caadbebcb7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Sun Oct 14 12:20:26 UTC 2018
+pkgbase = teaftp
+ pkgdesc = Simple, read-only TFTP server
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/xyproto/teaftp
+ arch = x86_64
+ license = MIT
+ makedepends = go
+ makedepends = git
+ source = git+https://github.com/xyproto/teaftp#tag=v1.0.0
+ md5sums = SKIP
+
+pkgname = teaftp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bfe7b3232b1e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
+
+pkgname=teaftp
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='Simple, read-only TFTP server'
+arch=('x86_64')
+url='https://github.com/xyproto/teaftp'
+license=('MIT')
+makedepends=('go' 'git')
+source=("git+https://github.com/xyproto/teaftp#tag=v$pkgver")
+md5sums=('SKIP')
+
+build() {
+ cd "$pkgname"
+
+ GO111MODULE=off go build
+}
+
+package() {
+ cd "$pkgname"
+
+ install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim: ts=2 sw=2 et: