summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2021-07-31 12:40:25 +0300
committerCaleb Maclennan2021-07-31 12:40:25 +0300
commit86d59334dc3f1d9a7de0bb4c7183e3594dddce45 (patch)
treed2500fe61b64926ef30d09d46872603af591f7c8
downloadaur-86d59334dc3f1d9a7de0bb4c7183e3594dddce45.tar.gz
Initial upload: teal 0.13.2-1
-rw-r--r--.SRCINFO43
-rw-r--r--PKGBUILD55
2 files changed, 98 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..df6181cefcd2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,43 @@
+pkgbase = teal
+ pkgdesc = The compiler for Teal, a typed dialect of Lua
+ pkgver = 0.13.2
+ pkgrel = 1
+ url = https://github.com/teal-language/tl
+ arch = any
+ license = MIT
+ makedepends = lua
+ makedepends = lua53
+ makedepends = lua52
+ makedepends = lua51
+ makedepends = luarocks
+ source = teal-0.13.2.tar.gz::https://github.com/teal-language/tl/archive/refs/tags/v0.13.2.tar.gz
+ sha256sums = a42c8dd1719933de027f8954b3edd4b255785d933f6ff183ae32bbf8adc7c6ae
+
+pkgname = teal
+ depends = lua
+ depends = lua-tl
+ provides = tl
+
+pkgname = lua-tl
+ depends = lua
+ depends = lua-argparse
+ depends = lua-compat53
+ depends = lua-filesystem
+
+pkgname = lua53-tl
+ depends = lua53
+ depends = lua53-argparse
+ depends = lua53-compat53
+ depends = lua53-filesystem
+
+pkgname = lua52-tl
+ depends = lua52
+ depends = lua52-argparse
+ depends = lua52-compat53
+ depends = lua52-filesystem
+
+pkgname = lua51-tl
+ depends = lua51
+ depends = lua51-argparse
+ depends = lua51-compat53
+ depends = lua51-filesystem
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..07cf5cea7a87
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
+pkgbase=teal
+_rockname=tl
+pkgname=(teal "lua-$_rockname" "lua53-$_rockname" "lua52-$_rockname" "lua51-$_rockname")
+pkgver=0.13.2
+pkgrel=1
+pkgdesc="The compiler for Teal, a typed dialect of Lua"
+arch=(any)
+url=https://github.com/teal-language/tl
+license=(MIT)
+_lua_deps=(argparse
+ compat53
+ filesystem)
+makedepends=(lua lua53 lua52 lua51 luarocks)
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('a42c8dd1719933de027f8954b3edd4b255785d933f6ff183ae32bbf8adc7c6ae')
+
+_package_helper() {
+ cd "$_rockname-$pkgver"
+ luarocks --lua-version=$1 --tree="$pkgdir/usr/" \
+ make --deps-mode=none --no-manifest "$_rockname-dev-1.rockspec"
+ if [[ -n $2 ]]; then
+ find "$pkgdir/usr/bin" -type f -execdir sed -i -e "s#$pkgdir##" {} \;
+ rm -rf "$pkgdir/usr/"{lib,share}
+ else
+ rm -rf "$pkgdir/usr/bin"
+ fi
+}
+
+package_teal() {
+ depends+=(lua lua-tl)
+ provides+=(tl)
+ _package_helper 5.4 bin
+}
+
+package_lua-tl() {
+ depends+=(lua "${_lua_deps[@]/#/lua-}")
+ _package_helper 5.4
+}
+
+package_lua53-tl() {
+ depends+=(lua53 "${_lua_deps[@]/#/lua53-}")
+ _package_helper 5.3
+}
+
+package_lua52-tl() {
+ depends+=(lua52 "${_lua_deps[@]/#/lua52-}")
+ _package_helper 5.2
+}
+
+package_lua51-tl() {
+ depends+=(lua51 "${_lua_deps[@]/#/lua51-}")
+ _package_helper 5.1
+}