summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorÓscar García Amor2019-12-10 19:40:36 +0100
committerÓscar García Amor2019-12-10 19:40:36 +0100
commit515579fc3fac5a4c02b5e50096b05a586ee0117a (patch)
tree957b1fe5427df5ddb6bb49b1bb251c590183f61f
downloadaur-515579fc3fac5a4c02b5e50096b05a586ee0117a.tar.gz
Initial upload: teams 1.2.00.32451-1
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD23
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..21c1ff1af0a8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = teams
+ pkgdesc = Microsoft Teams for Linux is your chat-centered workspace in Office 365
+ pkgver = 1.2.00.32451
+ pkgrel = 1
+ url = https://packages.microsoft.com/repos/ms-teams/pool/main/t/teams
+ arch = x86_64
+ license = custom
+ depends = gtk3
+ depends = libxss
+ depends = alsa-lib
+ depends = libxtst
+ depends = libsecret
+ depends = nss
+ depends = glibc>=2.28-4
+ optdepends = gnome-keyring
+ noextract = teams_1.2.00.32451_amd64.deb
+ source = https://packages.microsoft.com/repos/ms-teams/pool/main/t/teams/teams_1.2.00.32451_amd64.deb
+ sha256sums = 28d8a0e644a4bb9d4ee9295953b97b7fa6558b8a9d1d28363a594f5cde1c05dc
+
+pkgname = teams
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..854144f1f298
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: "Amhairghin" Oscar Garcia Amor (https://ogarcia.me)
+
+pkgname=teams
+pkgver=1.2.00.32451
+pkgrel=1
+pkgdesc="Microsoft Teams for Linux is your chat-centered workspace in Office 365"
+arch=('x86_64')
+url="https://packages.microsoft.com/repos/ms-teams/pool/main/t/teams"
+license=('custom')
+depends=("gtk3" "libxss" "alsa-lib" "libxtst" "libsecret" "nss" "glibc>=2.28-4")
+optdepends=("gnome-keyring")
+source=("https://packages.microsoft.com/repos/ms-teams/pool/main/t/teams/${pkgname}_${pkgver}_amd64.deb")
+noextract=("${pkgname}_${pkgver}_amd64.deb")
+sha256sums=('28d8a0e644a4bb9d4ee9295953b97b7fa6558b8a9d1d28363a594f5cde1c05dc')
+
+package() {
+ bsdtar -O -xf "${pkgname}_${pkgver}_amd64.deb" data.tar.xz | bsdtar -C "${pkgdir}" -xJf -
+
+ # Move license
+ install -dm755 "${pkgdir}/usr/share/licenses/${pkgname}"
+ mv "${pkgdir}/usr/share/${pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}"
+ ln -s "/usr/share/licenses/${pkgname}/LICENSE" "${pkgdir}/usr/share/${pkgname}/LICENSE"
+}