summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorivelkov2018-04-03 18:36:36 +0300
committerivelkov2018-04-03 18:36:36 +0300
commit55eb82ed6ed76b05724d477ce0537e0394cb4abd (patch)
treefed5c9b45253a2c677eedd5f82d3a6883fe9a706
downloadaur-55eb82ed6ed76b05724d477ce0537e0394cb4abd.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD55
2 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..81d31088794f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = teams-for-linux
+ pkgdesc = Unofficial Microsoft Teams client for Linux using Electron.
+ pkgver = 0.0.7
+ pkgrel = 1
+ url = https://github.com/ivelkov/teams-for-linux
+ arch = any
+ license = GPLv3
+ makedepends = npm
+ depends = electron
+ depends = xdg-utils
+ provides = teams-for-linux-0.0.7
+ conflicts = teams-for-linux-0.0.7
+ source = https://github.com/ivelkov/teams-for-linux/archive/v0.0.7.tar.gz
+ sha1sums = SKIP
+
+pkgname = teams-for-linux
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..23a616a15008
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Ivelin Velkov <ivelin dot velkov at gmail dot com>
+
+pkgname=teams-for-linux
+_pkgname=teams-for-linux-0.0.7
+pkgver=0.0.7
+pkgrel=1
+pkgdesc='Unofficial Microsoft Teams client for Linux using Electron.'
+arch=('any')
+url='https://github.com/ivelkov/teams-for-linux'
+license=('GPLv3')
+depends=('electron' 'xdg-utils')
+makedepends=( 'npm' )
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("https://github.com/ivelkov/$pkgname/archive/v$pkgver.tar.gz")
+
+sha1sums=('SKIP')
+_desktop="${_pkgname}.desktop"
+
+prepare() {
+ cat > ${_desktop} << EOF
+[Desktop Entry]
+Type=Application
+Name=Teams
+Comment=Unofficial Microsoft Teams client for Linux.
+Exec=/usr/bin/${pkgname}
+Icon=$pkgdir/usr/share/icons/hicolor/1024x1024/apps/teams-for-linux.png
+Categories=Network;InstantMessaging;Application;
+Terminal=false
+StartupNotify=true
+Version=${pkgver}
+EOF
+
+ cat > "${_pkgname}.sh" << EOF
+#!/usr/bin/env sh
+electron /usr/share/${pkgname}/app \$*
+EOF
+}
+
+build() {
+ cd "${_pkgname}"
+ npm i && (cd app && npm i)
+}
+
+package() {
+ cd "${_pkgname}"
+
+ install -Dm644 LICENSE.md "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+ cp -r --preserve=mode . "${pkgdir}/usr/share/${pkgname}"
+
+ install -Dm644 "build/icons/1024x1024.png" "${pkgdir}/usr/share/icons/hicolor/1024x1024/apps/teams-for-linux.png"
+ install -Dm644 "${srcdir}/${_desktop}" "${pkgdir}/usr/share/applications/${_desktop}"
+ install -Dm755 "${srcdir}/${_pkgname}.sh" "${pkgdir}/usr/bin/${pkgname}"
+ ln -s "${pkgdir}/usr/bin/${pkgname}" "${pkgdir}/usr/bin/teams"
+}