summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrealgagu2018-11-28 11:33:50 -0500
committerfrealgagu2018-11-28 11:33:50 -0500
commit9703600205325aba4bfc6a2b400c301be8648569 (patch)
tree1fa67961605a2d9c0552436195df3ed60e277870
parent5a203095e7ef9755d49ca189b9d4fab3767a2983 (diff)
downloadaur-9703600205325aba4bfc6a2b400c301be8648569.tar.gz
Upgrading to version 0.1.9 using the upstream https://github.com/IsmaelMartinez/teams-for-linux
-rw-r--r--.SRCINFO28
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD79
-rw-r--r--teams-for-linux.desktop11
4 files changed, 68 insertions, 56 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 71490bfec8c5..a0f80b9428f3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,21 @@
pkgbase = teams-for-linux
pkgdesc = Unofficial Microsoft Teams client for Linux using Electron.
- pkgver = 0.0.7
- pkgrel = 3
- url = https://github.com/ivelkov/teams-for-linux
- arch = any
- license = GPLv3
- makedepends = npm
- depends = electron
- depends = xdg-utils
- provides = teams-for-linux-0.0.7
- conflicts = teams-for-linux-0.0.7
- source = https://github.com/ivelkov/teams-for-linux/archive/v0.0.7.tar.gz
- sha1sums = SKIP
+ pkgver = 0.1.9
+ pkgrel = 1
+ url = https://github.com/IsmaelMartinez/teams-for-linux
+ arch = aarch64
+ arch = armv7h
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = yarn
+ depends = gtk3
+ depends = libxss
+ depends = nss
+ source = teams-for-linux-0.1.9.tar.gz::https://github.com/IsmaelMartinez/teams-for-linux/archive/v0.1.9.tar.gz
+ source = teams-for-linux.desktop
+ sha256sums = 9bd286226e25753365850a50c69d574ad5789105c062b3332c88dc62e6d0e0e7
+ sha256sums = f33ab4997c329567bbe172fe77ee6cbced5c5d4354e12ef52a89dd702422fded
pkgname = teams-for-linux
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..91e14276a3f7
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+teams-for-linux-*.pkg.tar.xz
+teams-for-linux-*.tar.gz
+teams-for-linux-*.log
+PKGBUILD-namcap.log
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
index b614bd905d27..b4716529a84b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,52 +1,43 @@
-# Maintainer: Ivelin Velkov <ivelin dot velkov at gmail dot com>
+# Maintainer: Fredy GarcĂ­a <frealgagu at gmail dot com>
+# Contributor: Ivelin Velkov <ivelin dot velkov at gmail dot com>
pkgname=teams-for-linux
-pkgver=0.0.7
-pkgrel=3
-pkgdesc='Unofficial Microsoft Teams client for Linux using Electron.'
-arch=('any')
-url='https://github.com/ivelkov/teams-for-linux'
-license=('GPLv3')
-depends=( 'nodejs' 'xdg-utils' 'electron' )
-makedepends=( 'npm' )
-provides=("${teams-for-linux}-${pkgver}")
-conflicts=("${teams-for-linux}-${pkgver}")
-source=("https://github.com/ivelkov/$pkgname/archive/v$pkgver.tar.gz")
-
-sha1sums=('SKIP')
-
-prepare() {
- cat > "${pkgname}.desktop" << EOF
-[Desktop Entry]
-Type=Application
-Name=Teams
-Comment=Unofficial Microsoft Teams client for Linux.
-Exec=/usr/bin/${pkgname}
-Icon=/usr/share/icons/hicolor/1024x1024/apps/teams-for-linux.png
-Categories=Network;InstantMessaging;Application;
-Terminal=false
-StartupNotify=true
-Version=${pkgver}
-EOF
-
- cat > "${pkgname}" << EOF
-#!/usr/bin/env sh
-electron /usr/share/${pkgname}/app \$*
-EOF
-}
+pkgver=0.1.9
+pkgrel=1
+pkgdesc="Unofficial Microsoft Teams client for Linux using Electron."
+arch=("aarch64" "armv7h" "i686" "x86_64")
+url="https://github.com/IsmaelMartinez/${pkgname}"
+license=("GPL3")
+depends=("gtk3" "libxss" "nss")
+makedepends=("yarn")
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/IsmaelMartinez/${pkgname}/archive/v${pkgver}.tar.gz"
+ "${pkgname}.desktop")
+sha256sums=("9bd286226e25753365850a50c69d574ad5789105c062b3332c88dc62e6d0e0e7"
+ "f33ab4997c329567bbe172fe77ee6cbced5c5d4354e12ef52a89dd702422fded")
build() {
- cd "$pkgname-$pkgver"
- npm install --production && (cd app && npm install --production)
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ yarn install --non-interactive --pure-lockfile --cache-folder "${srcdir}/yarn-cache"
+ if [[ ${CARCH} == "aarch64" ]]; then
+ yarn build --arm64 --linux dir
+ elif [[ ${CARCH} == "armv7h" ]]; then
+ yarn build --armv7l --linux dir
+ elif [[ ${CARCH} == "i686" ]]; then
+ yarn build --ia32 --linux dir
+ elif [[ ${CARCH} == "x86_64" ]]; then
+ yarn build --x64 --linux dir
+ fi
}
package() {
- cd "$pkgname-$pkgver"
-
- install -Dm644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- cp -r --preserve=mode . "${pkgdir}/usr/share/${pkgname}"
-
- install -Dm644 "build/icons/1024x1024.png" "${pkgdir}/usr/share/icons/hicolor/1024x1024/apps/teams-for-linux.png"
- install -Dm644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
- install -Dm755 "${srcdir}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -dm755 "${pkgdir}/opt" "${pkgdir}/usr/bin"
+ cp -r --preserve=mode "${srcdir}/${pkgname}-${pkgver}/dist/linux-unpacked" "${pkgdir}/opt/${pkgname}"
+ install -Dm644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ for _file in "${srcdir}/${pkgname}-${pkgver}/build/icons/"*.png
+ do
+ _filename="$(basename ${_file})"
+ install -Dm644 "${_file}" "${pkgdir}/usr/share/icons/hicolor/${_filename%.png}/apps/${pkgname}.png"
+ done
+ ln -sf "/opt/${pkgname}/${pkgname%-for-linux}" "${pkgdir}/usr/bin/${pkgname}"
}
diff --git a/teams-for-linux.desktop b/teams-for-linux.desktop
new file mode 100644
index 000000000000..7680790da76b
--- /dev/null
+++ b/teams-for-linux.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Type=Application
+Name=Microsoft Teams for Linux
+Comment=Unofficial Microsoft Teams client for Linux.
+GenericName=Teams
+Exec=teams-for-linux
+Icon=teams-for-linux
+Categories=Network;Chat;InstantMessaging;Application;
+Terminal=false
+StartupNotify=true
+Version=0.1.9