summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTilo Brueckner2017-04-16 11:14:47 +0200
committerTilo Brueckner2017-04-16 11:14:47 +0200
commit0738eb85472ba92e19900cbd71865a8643bd3c91 (patch)
tree0671f710aca9d59b48d5c5612d08f6d85e00e6c3
downloadaur-0738eb85472ba92e19900cbd71865a8643bd3c91.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD43
-rw-r--r--build-fixes.patch57
3 files changed, 119 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3170236c5107
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by makepkg 5.0.1
+# Sun Apr 16 09:08:20 UTC 2017
+pkgbase = teamspeak3-plugin-rp-soundboard
+ pkgdesc = Plugin for Teamspeak 3. Easy to use soundboard
+ pkgver = 1.3.3.1622
+ pkgrel = 1
+ url = https://github.com/MGraefe/RP-Soundboard
+ arch = i686
+ arch = x86_64
+ license = Unknown
+ makedepends = teamspeak3-pluginsdk>=3.1.0.1
+ depends = teamspeak3>=3.1.0.1
+ source = https://github.com/MGraefe/RP-Soundboard/archive/1.3.3.1622.tar.gz
+ source = build-fixes.patch
+ sha256sums = 1f7cb5436ec0a0bb61b5bfc1589412774717561e0ad1509dade419bfc1e5d5f4
+ sha256sums = 7560d100663d570eb2bc6f3c8f2f26b6837f6ceb9d585937d23fc15b70e3392b
+
+pkgname = teamspeak3-plugin-rp-soundboard
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a599fc71415
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Contributor: BluePeril <blueperil (at) blueperil _dot_ de>
+
+_pkgname=RP-Soundboard
+pkgname=teamspeak3-plugin-rp-soundboard
+pkgver=1.3.3.1622
+pkgrel=1
+pkgdesc='Plugin for Teamspeak 3. Easy to use soundboard'
+arch=('i686' 'x86_64')
+url="https://github.com/MGraefe/${_pkgname}"
+license=('Unknown')
+makedepends=('teamspeak3-pluginsdk>=3.1.0.1')
+depends=('teamspeak3>=3.1.0.1')
+source=("https://github.com/MGraefe/${_pkgname}/archive/${pkgver}.tar.gz"
+ 'build-fixes.patch')
+sha256sums=('1f7cb5436ec0a0bb61b5bfc1589412774717561e0ad1509dade419bfc1e5d5f4'
+ '7560d100663d570eb2bc6f3c8f2f26b6837f6ceb9d585937d23fc15b70e3392b')
+
+
+prepare() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ patch -p0 -i "${srcdir}/build-fixes.patch"
+ cd src/version
+ python version.py
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}/qt-linux"
+
+ export TS3DIR=/opt/teamspeak3
+ qmake ts3soundboard_linux.pro
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ mkdir -pm0755 ${pkgdir} "$pkgdir/opt/teamspeak3/plugins"
+ install -D -m644 bin/release_lin/librp_soundboard.so "$pkgdir/opt/teamspeak3/plugins/librp_soundboard.so"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/build-fixes.patch b/build-fixes.patch
new file mode 100644
index 000000000000..159d09040a4b
--- /dev/null
+++ b/build-fixes.patch
@@ -0,0 +1,57 @@
+--- qt-linux/ts3soundboard_linux.pro_orig 2017-04-16 11:03:14.429439051 +0200
++++ qt-linux/ts3soundboard_linux.pro 2017-04-16 11:03:38.873595978 +0200
+@@ -20,7 +20,7 @@
+ CONFIG(debug, release|debug):DEFINES += _DEBUG
+ CONFIG(release, release|debug):DEFINES += NDEBUG
+
+-INCLUDEPATH += ../include
++INCLUDEPATH += /usr/include/teamspeak3
+
+ LIBS += -L$(TS3DIR)
+
+@@ -29,7 +29,7 @@
+ -lavutil \
+ -lswresample
+
+-QMAKE_POST_LINK += "cp $${DESTDIR}/lib$${TARGET}.so $(TS3DIR)/plugins"
++# QMAKE_POST_LINK += "cp $${DESTDIR}/lib$${TARGET}.so $(TS3DIR)/plugins"
+
+
+ include(./ts3soundboard.pri)
+--- qt-linux/ts3soundboard.pri_orig 2017-04-16 11:03:52.417682394 +0200
++++ qt-linux/ts3soundboard.pri 2017-04-16 11:04:47.759031973 +0200
+@@ -22,6 +22,7 @@
+ ../src/SampleSource.h \
+ ../src/SampleVisualizerThread.h \
+ ../src/SoundInfo.h \
++ ../src/TalkStateManager.h \
+ ../src/ts3log.h \
+ ../src/version/version.h \
+ ../vs2015/resource.h \
+@@ -43,7 +44,7 @@
+ ../src/main.cpp \
+ ../src/HighResClock.cpp \
+ ../src/inputfileffmpeg.cpp \
+- ../src/plugin.c \
++ ../src/plugin.cpp \
+ ../src/SampleBuffer.cpp \
+ ../src/SampleProducerThread.cpp \
+ ../src/samples.cpp \
+@@ -53,6 +54,7 @@
+ ../src/soundsettings_qt.cpp \
+ ../src/soundview_qt.cpp \
+ ../src/SpeechBubble.cpp \
++ ../src/TalkStateManager.cpp \
+ ../src/ts3log.cpp \
+ ../src/UpdateChecker.cpp \
+ ../src/updater_qt.cpp
+--- src/samples.cpp_orig 2017-04-16 11:05:06.014146183 +0200
++++ src/samples.cpp 2017-04-16 11:05:27.003276895 +0200
+@@ -18,6 +18,7 @@
+ #include <queue>
+ #include <vector>
+ #include <cassert>
++#include <math.h>
+
+
+ #define USE_SSE2