summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTilo Brueckner2017-04-25 17:58:24 +0200
committerTilo Brueckner2017-04-25 17:58:24 +0200
commit215f4e2b99cafc7694efced6fa359e552919318c (patch)
treeb6d36f3c062afa6dc61421650c7e2013dea0e4be
parent0738eb85472ba92e19900cbd71865a8643bd3c91 (diff)
downloadaur-215f4e2b99cafc7694efced6fa359e552919318c.tar.gz
build against qt5.6 to avoid loading problems
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
-rw-r--r--build-fixes.patch29
3 files changed, 25 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3170236c5107..16af853d3ffa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
# Generated by makepkg 5.0.1
-# Sun Apr 16 09:08:20 UTC 2017
+# Tue Apr 25 15:52:39 UTC 2017
pkgbase = teamspeak3-plugin-rp-soundboard
pkgdesc = Plugin for Teamspeak 3. Easy to use soundboard
pkgver = 1.3.3.1622
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/MGraefe/RP-Soundboard
arch = i686
arch = x86_64
license = Unknown
makedepends = teamspeak3-pluginsdk>=3.1.0.1
+ makedepends = qt5.6
depends = teamspeak3>=3.1.0.1
source = https://github.com/MGraefe/RP-Soundboard/archive/1.3.3.1622.tar.gz
source = build-fixes.patch
sha256sums = 1f7cb5436ec0a0bb61b5bfc1589412774717561e0ad1509dade419bfc1e5d5f4
- sha256sums = 7560d100663d570eb2bc6f3c8f2f26b6837f6ceb9d585937d23fc15b70e3392b
+ sha256sums = d23d2c5d4cc58d21593b42a5a85e207021fb4a98085fe73a29d05619fc78833b
pkgname = teamspeak3-plugin-rp-soundboard
diff --git a/PKGBUILD b/PKGBUILD
index 6a599fc71415..8ca9c8c4a1b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,17 @@
_pkgname=RP-Soundboard
pkgname=teamspeak3-plugin-rp-soundboard
pkgver=1.3.3.1622
-pkgrel=1
+pkgrel=2
pkgdesc='Plugin for Teamspeak 3. Easy to use soundboard'
arch=('i686' 'x86_64')
url="https://github.com/MGraefe/${_pkgname}"
license=('Unknown')
-makedepends=('teamspeak3-pluginsdk>=3.1.0.1')
+makedepends=('teamspeak3-pluginsdk>=3.1.0.1' 'qt5.6')
depends=('teamspeak3>=3.1.0.1')
source=("https://github.com/MGraefe/${_pkgname}/archive/${pkgver}.tar.gz"
'build-fixes.patch')
sha256sums=('1f7cb5436ec0a0bb61b5bfc1589412774717561e0ad1509dade419bfc1e5d5f4'
- '7560d100663d570eb2bc6f3c8f2f26b6837f6ceb9d585937d23fc15b70e3392b')
+ 'd23d2c5d4cc58d21593b42a5a85e207021fb4a98085fe73a29d05619fc78833b')
prepare() {
@@ -28,7 +28,7 @@ build() {
cd "${srcdir}/${_pkgname}-${pkgver}/qt-linux"
export TS3DIR=/opt/teamspeak3
- qmake ts3soundboard_linux.pro
+ /opt/qt5.6/bin/qmake ts3soundboard_linux.pro
make
}
diff --git a/build-fixes.patch b/build-fixes.patch
index 159d09040a4b..2f9b8f3f8473 100644
--- a/build-fixes.patch
+++ b/build-fixes.patch
@@ -1,15 +1,20 @@
---- qt-linux/ts3soundboard_linux.pro_orig 2017-04-16 11:03:14.429439051 +0200
-+++ qt-linux/ts3soundboard_linux.pro 2017-04-16 11:03:38.873595978 +0200
-@@ -20,7 +20,7 @@
+--- qt-linux/ts3soundboard_linux.pro_orig 2017-04-25 08:23:53.644282489 +0200
++++ qt-linux/ts3soundboard_linux.pro 2017-04-25 08:26:55.262605010 +0200
+@@ -20,7 +20,12 @@
CONFIG(debug, release|debug):DEFINES += _DEBUG
CONFIG(release, release|debug):DEFINES += NDEBUG
-INCLUDEPATH += ../include
++INCLUDEPATH += /opt/qt5.6/include
++INCLUDEPATH += /opt/qt5.6/include/QtWidgets
++INCLUDEPATH += /opt/qt5.6/include/QtGui
++INCLUDEPATH += /opt/qt5.6/include/QtNetwork
++INCLUDEPATH += /opt/qt5.6/include/QtCore
+INCLUDEPATH += /usr/include/teamspeak3
LIBS += -L$(TS3DIR)
-@@ -29,7 +29,7 @@
+@@ -29,7 +34,7 @@
-lavutil \
-lswresample
@@ -18,9 +23,9 @@
include(./ts3soundboard.pri)
---- qt-linux/ts3soundboard.pri_orig 2017-04-16 11:03:52.417682394 +0200
-+++ qt-linux/ts3soundboard.pri 2017-04-16 11:04:47.759031973 +0200
-@@ -22,6 +22,7 @@
+--- qt-linux/ts3soundboard.pri_orig 2017-04-16 11:03:52.417682394 +0200
++++ qt-linux/ts3soundboard.pri 2017-04-16 11:04:47.759031973 +0200
+@@ -22,6 +22,7 @@
../src/SampleSource.h \
../src/SampleVisualizerThread.h \
../src/SoundInfo.h \
@@ -28,7 +33,7 @@
../src/ts3log.h \
../src/version/version.h \
../vs2015/resource.h \
-@@ -43,7 +44,7 @@
+@@ -43,7 +44,7 @@
../src/main.cpp \
../src/HighResClock.cpp \
../src/inputfileffmpeg.cpp \
@@ -37,7 +42,7 @@
../src/SampleBuffer.cpp \
../src/SampleProducerThread.cpp \
../src/samples.cpp \
-@@ -53,6 +54,7 @@
+@@ -53,6 +54,7 @@
../src/soundsettings_qt.cpp \
../src/soundview_qt.cpp \
../src/SpeechBubble.cpp \
@@ -45,9 +50,9 @@
../src/ts3log.cpp \
../src/UpdateChecker.cpp \
../src/updater_qt.cpp
---- src/samples.cpp_orig 2017-04-16 11:05:06.014146183 +0200
-+++ src/samples.cpp 2017-04-16 11:05:27.003276895 +0200
-@@ -18,6 +18,7 @@
+--- src/samples.cpp_orig 2017-04-16 11:05:06.014146183 +0200
++++ src/samples.cpp 2017-04-16 11:05:27.003276895 +0200
+@@ -18,6 +18,7 @@
#include <queue>
#include <vector>
#include <cassert>