summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTilo Brueckner2019-06-20 20:18:07 +0200
committerTilo Brueckner2019-06-20 20:18:07 +0200
commit94150a27bb36380d559dda533c3570aeefa3ddf0 (patch)
treee0c946e8a6269fc44fd0bbd43a0df62b2db7c1fa
parent1687bbf79fe2aa11d922a9a048c998e42e04ada8 (diff)
downloadaur-94150a27bb36380d559dda533c3570aeefa3ddf0.tar.gz
Update to version 1.4.1.1810
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD12
-rw-r--r--build-fixes.patch56
3 files changed, 32 insertions, 55 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 83a484b74321..992ff5a99d32 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,21 @@
-# Generated by makepkg 5.0.2
-# Sat Jul 22 14:42:00 UTC 2017
+# Generated by makepkg 5.1.3
+# Thu Jun 20 13:22:28 UTC 2019
pkgbase = teamspeak3-plugin-rp-soundboard
pkgdesc = Plugin for Teamspeak 3. Easy to use soundboard
- pkgver = 1.3.5.1733
+ pkgver = 1.4.1.1810
pkgrel = 1
url = https://github.com/MGraefe/RP-Soundboard
arch = x86_64
license = Unknown
- makedepends = teamspeak3-pluginsdk>=3.1.0.1
- makedepends = qt5.6
+ makedepends = teamspeak3-pluginsdk>=3.3.0
makedepends = python
- depends = teamspeak3>=3.1.0.1
- source = https://github.com/MGraefe/RP-Soundboard/archive/1.3.5.1733.tar.gz
+ makedepends = qt5-base
+ makedepends = ffmpeg
+ depends = teamspeak3>=3.3.0
+ source = https://github.com/MGraefe/RP-Soundboard/archive/1.4.1.1810.tar.gz
source = build-fixes.patch
- sha256sums = c83bf9a431e9e27d9b780304a9bbb0e4da258a74dcc3fc8848fa264b8f2966ca
- sha256sums = 940e5c41e000df005b280693c34888fb0131953378e501ffc375ed9bd1c87953
+ sha256sums = af00598fdfada9bc3f8000824b572236c0be6db51398600f869cdf1a88ea5064
+ sha256sums = 8cbfe1d695c5c3477e6c28a649c29575d82720c30c48a74de0c8162ade05efbc
pkgname = teamspeak3-plugin-rp-soundboard
diff --git a/PKGBUILD b/PKGBUILD
index 1e65ab5ab89c..ec791ad30839 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,18 @@
_pkgname=RP-Soundboard
pkgname=teamspeak3-plugin-rp-soundboard
-pkgver=1.3.5.1733
+pkgver=1.4.1.1810
pkgrel=1
pkgdesc='Plugin for Teamspeak 3. Easy to use soundboard'
arch=('x86_64')
url="https://github.com/MGraefe/${_pkgname}"
license=('Unknown')
-makedepends=('teamspeak3-pluginsdk>=3.1.0.1' 'qt5.6' 'python')
-depends=('teamspeak3>=3.1.0.1')
+makedepends=('teamspeak3-pluginsdk>=3.3.0' 'python' 'qt5-base' 'ffmpeg')
+depends=('teamspeak3>=3.3.0')
source=("https://github.com/MGraefe/${_pkgname}/archive/${pkgver}.tar.gz"
'build-fixes.patch')
-sha256sums=('c83bf9a431e9e27d9b780304a9bbb0e4da258a74dcc3fc8848fa264b8f2966ca'
- '940e5c41e000df005b280693c34888fb0131953378e501ffc375ed9bd1c87953')
+sha256sums=('af00598fdfada9bc3f8000824b572236c0be6db51398600f869cdf1a88ea5064'
+ '8cbfe1d695c5c3477e6c28a649c29575d82720c30c48a74de0c8162ade05efbc')
prepare() {
cd "${_pkgname}-${pkgver}"
@@ -28,7 +28,7 @@ build() {
cd "${_pkgname}-${pkgver}/qt-linux"
export TS3DIR=/opt/teamspeak3
- /opt/qt5.6/bin/qmake ts3soundboard_linux.pro
+ qmake ts3soundboard_linux.pro
make
}
diff --git a/build-fixes.patch b/build-fixes.patch
index 6a77ff5810c3..0612bd35a44d 100644
--- a/build-fixes.patch
+++ b/build-fixes.patch
@@ -1,46 +1,22 @@
---- qt-linux/ts3soundboard_linux.pro_orig 2017-06-25 13:04:17.367485782 +0200
-+++ qt-linux/ts3soundboard_linux.pro 2017-06-25 13:05:46.234153803 +0200
-@@ -20,7 +20,12 @@
- CONFIG(debug, release|debug):DEFINES += _DEBUG
- CONFIG(release, release|debug):DEFINES += NDEBUG
-
--INCLUDEPATH += ../include
-+INCLUDEPATH += /opt/qt5.6/include
-+INCLUDEPATH += /opt/qt5.6/include/QtWidgets
-+INCLUDEPATH += /opt/qt5.6/include/QtGui
-+INCLUDEPATH += /opt/qt5.6/include/QtNetwork
-+INCLUDEPATH += /opt/qt5.6/include/QtCore
-+INCLUDEPATH += /usr/include/teamspeak3
-
- LIBS += -L$(TS3DIR)
-
-@@ -29,7 +34,7 @@
- -lavutil \
- -lswresample
+--- src/inputfileffmpeg.cpp_orig 2019-06-20 14:42:36.187742498 +0200
++++ src/inputfileffmpeg.cpp 2019-06-20 14:43:27.288343432 +0200
+@@ -416,7 +416,7 @@
+
+ if(properFrames == 0)
+ {
+- if(m_codecCtx->codec->capabilities & CODEC_CAP_DELAY && m_convertedSamples < m_decodedSamplesTargetSR)
++ if(m_codecCtx->codec->capabilities & AV_CODEC_CAP_DELAY && m_convertedSamples < m_decodedSamplesTargetSR)
+ {
+ // Some codecs will cause frames to be buffered up in the decoding process. If the CODEC_CAP_DELAY flag
+ // is set, there can be buffered up frames that need to be flushed, so we'll do that
+--- qt-linux/ts3soundboard_linux.pro_orig 2019-06-20 14:48:44.728813522 +0200
++++ qt-linux/ts3soundboard_linux.pro 2019-06-20 14:48:51.490788441 +0200
+@@ -36,7 +36,7 @@
+
+ QMAKE_CXXFLAGS += -Wno-unused-parameter
-QMAKE_POST_LINK += "cp $${DESTDIR}/lib$${TARGET}.so $(TS3DIR)/plugins"
+#QMAKE_POST_LINK += "cp $${DESTDIR}/lib$${TARGET}.so $(TS3DIR)/plugins"
-
include(./ts3soundboard.pri)
---- src/peakmeter.h_orig 2017-06-25 13:09:23.183737983 +0200
-+++ src/peakmeter.h 2017-06-25 13:10:14.383142304 +0200
-@@ -5,6 +5,7 @@
- // All rights reserved
- // Contact: rp_soundboard@mgraefe.de
- //----------------------------------
-+#include <math.h>
-
- #pragma once
- #ifndef rpsbsrc__peakmeter_H__
---- src/UpdateChecker.h_orig 2017-07-22 13:25:43.865108011 +0200
-+++ src/UpdateChecker.h 2017-07-22 13:26:21.277227454 +0200
-@@ -39,7 +39,7 @@
-
- public:
- explicit UpdateChecker(QObject *parent = NULL);
-- void startCheck(bool explicitCheck = true, ConfigModel *config = false);
-+ void startCheck(bool explicitCheck = true, ConfigModel *config = NULL);
- static QByteArray getUserAgent();
- static void setUserAgent(QNetworkRequest &request);