summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTilo Brueckner2021-05-06 18:32:07 +0200
committerTilo Brueckner2021-05-06 18:32:07 +0200
commitaa1482699c2461e973221f66b15874e91f9da1fe (patch)
tree396ebad427b0183afcb4e8f33c767bcbd6a05563
parent94150a27bb36380d559dda533c3570aeefa3ddf0 (diff)
downloadaur-aa1482699c2461e973221f66b15874e91f9da1fe.tar.gz
Update to version 1.4.1.1826
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
-rw-r--r--build-fixes.patch35
3 files changed, 47 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 992ff5a99d32..4adbee33bf2a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,22 @@
-# Generated by makepkg 5.1.3
-# Thu Jun 20 13:22:28 UTC 2019
+# Generated by makepkg 5.2.2
+# Thu May 6 16:30:01 UTC 2021
pkgbase = teamspeak3-plugin-rp-soundboard
pkgdesc = Plugin for Teamspeak 3. Easy to use soundboard
- pkgver = 1.4.1.1810
+ pkgver = 1.4.1.1826
pkgrel = 1
url = https://github.com/MGraefe/RP-Soundboard
arch = x86_64
license = Unknown
- makedepends = teamspeak3-pluginsdk>=3.3.0
makedepends = python
makedepends = qt5-base
makedepends = ffmpeg
depends = teamspeak3>=3.3.0
- source = https://github.com/MGraefe/RP-Soundboard/archive/1.4.1.1810.tar.gz
+ source = https://github.com/MGraefe/RP-Soundboard/archive/refs/tags/1.4.1.1826_linux.tar.gz
+ source = Updated_API_QT_5.10.patch::https://github.com/MGraefe/RP-Soundboard/commit/a7653d62fe84d71cdcddf4b614b1a0083fc2deec.patch
source = build-fixes.patch
- sha256sums = af00598fdfada9bc3f8000824b572236c0be6db51398600f869cdf1a88ea5064
- sha256sums = 8cbfe1d695c5c3477e6c28a649c29575d82720c30c48a74de0c8162ade05efbc
+ sha256sums = aa70fe9db89c404c3f11aafc508e1d2618123bae7085cc543c91c7333c68ff48
+ sha256sums = 339889edd44b10bf153d9bac083e92e73f886d1aa87fab1f5edd6d4ae9c19bc9
+ sha256sums = 2866dec7059697df0030968549b67faedd5af78636269e6d84334a722817c2db
pkgname = teamspeak3-plugin-rp-soundboard
diff --git a/PKGBUILD b/PKGBUILD
index ec791ad30839..3798d3fc6486 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,42 +2,47 @@
_pkgname=RP-Soundboard
pkgname=teamspeak3-plugin-rp-soundboard
-pkgver=1.4.1.1810
+pkgver=1.4.1.1826
pkgrel=1
pkgdesc='Plugin for Teamspeak 3. Easy to use soundboard'
arch=('x86_64')
url="https://github.com/MGraefe/${_pkgname}"
license=('Unknown')
-makedepends=('teamspeak3-pluginsdk>=3.3.0' 'python' 'qt5-base' 'ffmpeg')
+makedepends=('python' 'qt5-base' 'ffmpeg')
depends=('teamspeak3>=3.3.0')
-source=("https://github.com/MGraefe/${_pkgname}/archive/${pkgver}.tar.gz"
+source=("https://github.com/MGraefe/${_pkgname}/archive/refs/tags/${pkgver}_linux.tar.gz"
+ 'Updated_API_QT_5.10.patch'::'https://github.com/MGraefe/RP-Soundboard/commit/a7653d62fe84d71cdcddf4b614b1a0083fc2deec.patch'
'build-fixes.patch')
-sha256sums=('af00598fdfada9bc3f8000824b572236c0be6db51398600f869cdf1a88ea5064'
- '8cbfe1d695c5c3477e6c28a649c29575d82720c30c48a74de0c8162ade05efbc')
+sha256sums=('aa70fe9db89c404c3f11aafc508e1d2618123bae7085cc543c91c7333c68ff48'
+ '339889edd44b10bf153d9bac083e92e73f886d1aa87fab1f5edd6d4ae9c19bc9'
+ '2866dec7059697df0030968549b67faedd5af78636269e6d84334a722817c2db')
prepare() {
- cd "${_pkgname}-${pkgver}"
+ cd "${_pkgname}-${pkgver}_linux"
- patch -p0 -i "${srcdir}/build-fixes.patch"
+ patch -p1 -i ../Updated_API_QT_5.10.patch
+ patch -p1 -i ../build-fixes.patch
+
+ rm -rf build
+ mkdir build
cd src/version
python version.py
}
build() {
- cd "${_pkgname}-${pkgver}/qt-linux"
+ cd "${_pkgname}-${pkgver}_linux/build"
- export TS3DIR=/opt/teamspeak3
- qmake ts3soundboard_linux.pro
+ cmake .. -DCMAKE_BUILD_TYPE=Release -DCMAKE_LIBRARY_PATH=/usr/lib
make
}
package() {
- cd "${_pkgname}-${pkgver}"
+ cd "${_pkgname}-${pkgver}_linux/build"
mkdir -pm0755 ${pkgdir} "$pkgdir/opt/teamspeak3/plugins"
- install -D -m644 bin/release_lin/librp_soundboard.so "$pkgdir/opt/teamspeak3/plugins/librp_soundboard.so"
+ install -D -m644 librp_soundboard_linux_amd64.so "$pkgdir/opt/teamspeak3/plugins/librp_soundboard.so"
}
# vim:set ts=2 sw=2 et:
diff --git a/build-fixes.patch b/build-fixes.patch
index 0612bd35a44d..ffd9e876ec18 100644
--- a/build-fixes.patch
+++ b/build-fixes.patch
@@ -1,5 +1,25 @@
---- src/inputfileffmpeg.cpp_orig 2019-06-20 14:42:36.187742498 +0200
-+++ src/inputfileffmpeg.cpp 2019-06-20 14:43:27.288343432 +0200
+--- a/CMakeLists.txt 2021-05-02 21:38:58.266305435 +0200
++++ b/CMakeLists.txt 2021-05-02 21:40:19.485151388 +0200
+@@ -5,7 +5,7 @@
+ include(files.cmake)
+
+ # Get prebuilt ffmpeg folders for windows builds
+-set(ffmpegIncHint "ffmpeg/include")
++set(ffmpegIncHint "/usr/include")
+
+ # figure out platform defaults for certain things
+ if (WIN32)
+@@ -34,7 +34,7 @@
+ endif()
+
+
+-set(ffmpegLibHint "${CMAKE_CURRENT_SOURCE_DIR}/${defFFmpegLibHint}" CACHE PATH "directory with static ffmpeg libs")
++set(ffmpegLibHint "/usr/lib" CACHE PATH "directory with static ffmpeg libs")
+ set(libSuffix ${defLibSuffix} CACHE STRING "output library suffix")
+ set(pluginDir ${defPluginDir} CACHE PATH "TS3 plugin directory (for file copy)")
+
+--- a/src/inputfileffmpeg.cpp 2021-05-02 21:46:10.856210178 +0200
++++ b/src/inputfileffmpeg.cpp 2021-05-02 21:46:26.274256126 +0200
@@ -416,7 +416,7 @@
if(properFrames == 0)
@@ -9,14 +29,3 @@
{
// Some codecs will cause frames to be buffered up in the decoding process. If the CODEC_CAP_DELAY flag
// is set, there can be buffered up frames that need to be flushed, so we'll do that
---- qt-linux/ts3soundboard_linux.pro_orig 2019-06-20 14:48:44.728813522 +0200
-+++ qt-linux/ts3soundboard_linux.pro 2019-06-20 14:48:51.490788441 +0200
-@@ -36,7 +36,7 @@
-
- QMAKE_CXXFLAGS += -Wno-unused-parameter
-
--QMAKE_POST_LINK += "cp $${DESTDIR}/lib$${TARGET}.so $(TS3DIR)/plugins"
-+#QMAKE_POST_LINK += "cp $${DESTDIR}/lib$${TARGET}.so $(TS3DIR)/plugins"
-
- include(./ts3soundboard.pri)
-